Bahmni is not display Patient's local name in clinical module

Hi I’m Pi. I’m doctor in Thailand and want to implement Bahmni in my hospital But I have one big issue

when i enter Patient’s Thai name in local name field in Registration module, it won’t display Thai name in Clinical module (but displaying English name instead)

So I wonder about the solution of this. (This is quite critical because most Thai people don’t know their English name and reading patient’s English name will be troublesome for doctor)

This is registration form with Thai local name

1 Like

This is clinical module, isn’t display Thai name (circle in red)

also this

Hello Pi,

If you are ok to see the Thai name everywhere in Bahmni application as well as any printouts generated. Then entering Thai name in English name field should do the trick.

Hi it’s seem like I cannot any letter other than English in English name field

it’s show up like this when I saved.

Hi @zacrify, Can you check this Bahmni talk thread with similar requirement for Spanish alphanumeric characters. You have to add regex pattern for Thai characters.

@zacrify, out of the box with its default configuration, Bahmni limits to just A-Z in the names.

The linked talk thread that Bindu shared says more about this. Specifically you would need to make changes in two places:

  1. The registration module’s app.json as mentioned here.
  2. (depending on the Bahmni version you’re using) change the underlying OpenMRS advanced settings as mentioned here, maybe just setting “patient.nameValidationRegex” to be blank.

PS- @binduak, could you update the Bahmni wiki to describe how to change this setting, so that we can point people to official documentation of this in the future? (As far as having to change this within OpenMRS advanced settings, starting with OpenMRS Platform 2.0.0, there is no validation by default. So starting from whichever Bahmni version is the one that depends on OpenMRS Platform 2+ there’s no need to do anything in the OpenMRS settings, only the Bahmni app.json.

@darius Thank you for very quick response. I’m appreciated. I just try to fix it with what you refer to but it seem not working (it’ keep error with “Should contain characters” I’ve tried to change rewrite regex

and try to set the “patient.nameValidationRegex” blanking but it’s still not working

I also tried to change “patient.nameValidationRegex” field to [^ก-๛a-zA-Z’ ]|^’|’$|’’ but when did that Openmrs keep error

not sure what next to do?

@zacrify, which version of Bahmni are you running?

In version 0.88, you would need to change both settings.

Could you try with no validation at all?

"familyName" : {"pattern" : "[a-zA-Z]{0,}", "errorMessage" : "Accepts only roman characters"},
"givenName" : {"pattern" : "[a-zA-Z]{0,}", "errorMessage" : "Accepts only roman characters"},
"middleName" : {"pattern" : "[a-zA-Z]{0,}", "errorMessage" : "Accepts only roman characters"},

Then can you confirm that any character is accepted in the name fields?


@darius, I am surprised of this because there seem to be a validation set by default in Bahmni 0.88 (which uses Core 2.0.4):

1 Like

Hi @zacrify, We have updated this wiki page with the steps. ( @darius )

So appreciated for your real quick help I can do it in Thai right now :heart_eyes::heart_eyes::heart_eyes: Cheers

PS. Big thanks for new wiki that you just did