Bahmni Connect (0.89): ERR_INSECURE_RESPONSE

Hi guys,

I am currently trying to install Bahmni 0.89 to try Bahmni Connect. I have followed the steps in the doc (here)

But the wheel keeps spinning forever when loading the ‘bahmni-connect’ page:

No obvious error in the server log. But in the browser console there is:

An SSL certificate error occurred when fetching the script.
Failed to load resource: net::ERR_INSECURE_RESPONSE

Does this mean that I have to setup my SSL certs and all? Or is there any way to bypass this SSL verif. ?



Hi @mksrom, Bahmni Connect is based on Progressive Web Apps and you need to have valid SSL Certificates on the server. If you have a domain, you can generate the certificates very easily using LetsEncrypt. You can read about it here

Thanks for the prompt answer. No way to disable this right, even temporarily?

No way. You can read about it here

Thanks @bharatak, no more error after the certificates are installed. :thumbsup:

Hi @bharatak, reviving this old thread about having mandatory TLS certs to run Bahmni Connect. What you described certainly worked and solved my problem. We intend to access Bahmni Connect via TLS on all our remote servers.

However, I now want to making it run locally (for dev purposes) and it would make my life easier if I could avoid setting up TLS on my machine, fake an access via our domain name to localhost etc…

By reading this thread it seems that accessing via “localhost” should prevent the service worker to need a TLS cert:

There’s an exception to the HTTPS requirement in place to facilitate local development: if you access your page and service worker script via http://localhost[:port], or via http://127.x.y.z[:port], then service workers should be enabled without any further actions.

I have tried and it doesn’t work. At first I am automatically redirected to HTTPS and after disabling the Apache redirections, I get a empty page (like it is not the right port maybe)

(Q) How you guys are doing Bahmni Connect dev work?

For the record, I have finally found a way to make the Service Workers work on HTTPS on localhost with invalid TLS certs.

Launch a new Chrome window with the following options

google-chrome --user-data-dir=/tmp/foo --ignore-certificate-errors --unsafely-treat-insecure-origin-as-secure=https://localhost:443