Authorization failed for 403 Forbidden

Hi all,

I just ran into a bunch of errors while installing OpenMRS. I have forked the repo to my own github and managed to install OpenMRS yesterday evening from that repo. But now I’m getting the errors as shown in the pastebin renske@renske-Lenovo-ideapad-310-15ISK:~/Documents/openmrs-core$ mvn openmrs-sdk - I pulled the latest commits for the master branch, but no luck.

Can someone please help me out?


hello @renskelotte48 what your maven version ? that you are using

Hi, my maven version is 3.6.3.

There should be a file, ~/.m2/settings.xml, which should look like this file or at least have some similar sections. Can you remove this repository tag and this pluginRepository tag and then try re-running the command?


I edited the file. Now I’m getting the following output [INFO] ------------------------------------------------------------------------ - for the setup command

Can you post your settings.xml file on (with any passwords removed)?

<?xml version="1.0" encoding="UTF-8"?><settings xsi:schemaLocation="http://mav - (literal copy-paste, there’s no sensitive info)

Could you try running the mvn openmrs-sdk:setup command from a directory that isn’t the openmrs-core directory? (Literally any directory that doesn’t have a pom.xml file should be fine). I’m not entirely sure what’s happening, so I’m trying to eliminate some possible confounders.

I tried running it in Documents and Downloads (both don’t have pom files and log that during the installation). I get the exact same output. Have tried deleting every OpenMRS related directory and clone and reinstall the whole thing, with the same results

Ok… this is a much more destructive possibility but do you mind trying to remove the Maven cache (~/.m2/repository). Assuming you have a good internet connection, this shouldn’t be too much of a big deal, but if you don’t we might need to be more surgical in what we’re removing.

I removed that directory as well before reinstalling the last time (appr. 10 min ago) (removed openmrs and m2 dir in home, openmrs-core in documents)

@mogoodrich and @ball - this is the same issue that you were seeing locally this morning I believe. @ibacher - did Bintray already go away?

Ah… apparently this is a “scheduled brownout”. I was focusing on the fact that the call was trying to go to, which basically only ever had the SDK AFAIK).

Ah, that explains it I think. It’s down until 23:00 (Amsterdam time), so I’ll try again tomorrow. Will let you know if I run into the same error again. Thanks for your help!

But is this an warning of issues we are going to face a week from now, when Bintray goes away for good?

I think we have the Lab Workflow and Order Entry OWAs released to artifiactory, so those should be all set, but not sure about others.

Take care, Mark

We ran into issues today because of the build-distro goal of the SDK that relies on Bintray for the OWAs.

A bit scary indeed.

Cc @dkayiwa

@mksd the latest release of the SDK has an update that can pull OWAs in the build-distro goal from either bintray or artifactory. @ibacher has been working on getting all of the OWAs off of bintray (which he has) and getting them uploaded to artifactory with an appropriate artifact id (which I think is still a work in progress but defer to him). Once that is in place, there are some likely tweaks to be made to the openmrs distro properties files to reflect the new standard artifact ids (or at least that’s what I started doing for orderentry and labworkflow).


@renskelotte48 should be good now. Can you try again?

Alright, all the non-beta versions of OMRS OWAs that were in Bintray should now be available through Artifactory. Hopefully this doesn’t require any adjustments to people’s distro, but let me know if it does.

Thanks both @ibacher and @mseaton for your infos. And thanks @ibacher for being on the fence with this.

@frederic.deniger and/or I will try to upgrade the SDK and report back.