Announcing Bahmni 0.92 Release Candidate

I placed the dump file at var/lib/pgbackrest/clinlims folder

and also i created the dump file using this command for openlis which worked:

bahmni -i local backup --backup_type=db --options=clinlims

But then also command for openerp/Odoo didn’t create any backup folder like it usually do on Bahmni 0.91

bahmni -i local backup --backup_type=db --options=openerp

Hi Team, I am using v 0.92-142.noarch.rpm Whenever i change the product Category from the

> Inventory->Configuration->Product Category

ie rename the pre-configured categories the atomfeed stops working and cant get quotations

what might be the solution, I want to have products categorized by their location ie pharmacy, Lab service , Dental service , Maternity etc and not lab panel, Lab Test, injection, Lotion, Drop See attached me2

I can’t login mysql through Terminal any help?

[root@localhost ~]# mysql -uroot -ppassword openmrs
mysql: [Warning] Using a password on the command line interface can be insecure.
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

Try username : root password: P@ssw0rd

1 Like

This must correspond to the members of “Dose Quantity Units” in OpenMRS concept dictionary. Also, please don’t change the parent hierarchy, “All/Services/lab”, “All/Saleable/Drugs” etc

1 Like

I am trying to install bahmni 0.92 in vagrant centos but getting following error

fatal: [localhost]: FAILED! => {“changed”: false, “msg”: “Unable to start service openmrs: Job for openmrs.service failed because a configured resource limit was exceeded. See “systemctl status openmrs.service” and “journalctl -xe” for details.\n”}

can anyone suggest the solution ?

What configuration is your server? most like resources are issue - diskspace, memory etc.

Configuration of my machine is as follows:

total           used        free      shared  buff/cache   available

Mem:       12G        2.9G        8.8G         36M        934M        9.4G

Swap: 2.0G 0B 2.0G

/dev/sda1 40G 8.7G 32G 22%

devtmpfs 6.3G 0 6.3G 0% /dev

tmpfs 6.3G 4.0K 6.3G 1% /dev/shm

tmpfs 6.3G 8.7M 6.3G 1% /run

tmpfs 6.3G 0 6.3G 0% /sys/fs/cgroup

tmpfs 1.3G 0 1.3G 0% /run/user/1001

bahmni 134G 96G 38G 72% /bahmni

tmpfs 1.3G 0 1.3G 0% /run/user/1000

@angshuonline installing 0.92-142 0n Aws. Got this error “Unable to start service openmrs: Job for openmrs.service failed because a configured resource limit was exceeded.” Server configuration is

Filesystem

/dev/xvda1 Size 30G Used 9.9G Avail 21G Use% 34% Mounted on /

devtmpfs Size 473M Used 0 Avail 473M Use% 0% Mounted on /dev

tmpfs Size 495M Used 4.0K Avail 495M Use% 1% Mounted on /dev/shm

tmpfs Size 495M Used 20M Avail 476M Use% 4% Mounted on /run

tmpfs Size 495M Used 0 Avail 495M Use% 0% Mounted on /sys/fs/cgroup

tmpfs Size 99M Used 0 Avail 99M Use% 0% Mounted on /run/user/1001

tmpfs Size 99M Used 0 Avail 99M Use% 0% Mounted on /run/user/1000

We also faced the same issue in our new implementation. Could you please attach openmrs.log file so that we could study and suggest.

1 Like

Please find the attached openmrs.log herewith for your reference.openmrs.log.txt (16.1 KB)

@akshaybirajdar from your log, it seems that mysql connection is erroring out.
Can you check?

  • if mysqld is running

systemctl status mysqld

  • try logging onto mysql

mysql -uroot -p openmrs

the above would prompt you for password - try with your admin password (check wiki for default, if you have not overridden the mysql root password)

If successful, then try connecting as the user

mysql -uopenmrs-user -p openmrs

You will find the password in /etc/openmrs/openmrs-runtime.properties file.

Have you also tried restarting openmrs?

@laxman Was bahmni-emr installed? Have you checked the details of the install log? You can see that in /bahmni_temp/logs/bahmni_deploy.log

  • have you tried starting the openmrs service specifically?
  • try installing one component at a time - modify your inventory file, and only install bahmni-emr, and bahmni-reports to start with.
  • if the above is successful, then you can go back to the inventory file and add the rest of the components (like bahmni-lab, bahmni-erp etc). You can then selectively install one component at a time.

bahmni -i local --only bahmni-emr

bahmni -i local --only bahmni-reports

bahmni -i local --only bahmni-lab

(of course you can do this even at the first step process)

Openmrs service is running, mysqld also running. I can successfully login in mysql using database openmrs.

try with user “openmrs-user”. If yes, then stop openmrs and mysqld. start mysqld first and then start openmrs

Odoo is running, but the openmrs showing :This site cant be reached refused to connect". Openmrs service is running. Please find the attached openmrs.log herewith. Port 443 is defined in inbound security group on AWS. openmrs.log.txt (3.8 MB)

If might be an issue with port forwarding! not sure - I wouldn’t know about your specific group settings on AWS. The log says potentially some modules might not have been loaded. But the message “site can not be reached, refused to connect” etc - can be even due to inaccessibility to the service.

to check whether the service is actually, go to the server and check

curl http://localhost:8050/openmrs/

if it throws up a login page (html content), then you know that the server is up, its probably not forward the requests to openmrs service correctly.

Also check if any of the apache resources can be loaded.

https://your-server/bahmni_config/openmrs/apps/home/app.json

If that does not return you anything, then apache is not working properly.

The curl command shows a html page, but second command throws a blank web page showing “Refused to connect.” What is the solution for Apache not working properly?

  • the second URL you should execute from your browser (not from the server hosting bahmni). replace (your-server with IP or hostname)

I hope you have done the above.

Also , how is Odoo accessible? unless you are bypassing apache and exposing Odoo directly.

When I access from my local machine not from server, https://Server-IP/openmrs Shows Refused to connect and http://Server-IP:8069 shows Odoo login page and https://my-server-IP/ also shows Refused to connect.