Announcing Bahmni 0.92 Release Candidate

A new build is available at

I got an issue when installing EMR+ERP only (without installing OpenELIS).

created patients and orders are not syncing to odoo and this is the log from bahmni-erp-connect :

Cc: @angshuonline, @mksrom

1 Like

@zouchine Thanks for the logs. Investigating …

1 Like


Bug acknowledged. Can you put this file (/opt/bahmni-erp-connect/bahmni-erp-connect/WEB-INF/classes/ on pastebin, so that we can confirm our findings?

JIRA card: BAH-844

1 Like

I ran into this error for the version 0.92 ,while trying to create a concept,

whats the solution for this

this is the content of :

@ramashish @zouchine

  • The issue above is due to using “default” bahmni. if you use “default” implementation, (you can change that in setup.yml), bahmni installer is going to use the default-config and also start with a default database, where essential metadata and some sample data (like Diagnosis, Tests) etc are loaded. But it does not/should not have any data.
  • Seems like the base Odoo database dump for default - had a customer and order/order_line entries for that customer already.
  • When you create a patient in Clinical, the identifier for “bahmni patient identifier” probably starts from that number
  • When it syncs to Odoo, it identifies the existing customer (with the identifier) and thats how you see the “ghost” order :slight_smile:

We are going to be clean up the base db. that should resolve the problem.

At the same time, I would urge - start afresh from a configuration that is not named “default” - its going to take a little work to setup the metadata, but its worthwhile.

Registered Bug BAH-847


Confirmed. We are fixing this. In the meantime, you can edit the same file and add the following lines to get it working.

1 Like

@stephencoduor replied on the other thread. Let us know

Hey I get Bahmni addons error on Centos 7.6 .

2019-07-06 11:22:45,243 17740 ERROR odoo odoo.modules.registry: Model atom.event.worker has no table.

2019-07-06 11:22:45,305 17740 ERROR odoo odoo.modules.registry: Model has no table.

2019-07-06 11:22:45,305 17740 ERROR odoo odoo.modules.registry: Model has no table.

2019-07-06 11:22:45,306 17740 ERROR odoo odoo.modules.registry: Model product.uom.service has no table.

2019-07-06 11:22:45,306 17740 ERROR odoo odoo.modules.registry: Model has no table.

Detailed error here pastebin

The above should not stop Odoo or Clinical-ERP functions. We will fix the error reporting. Thanks.

@stephencoduor What exactly is the error you are facing?

  • do you find that your odoo is running, but the menus not loading?
  • if yes, can you check for any error reported on browser console (or use chrome devtools to check)?
  • Do you see error like “JQuery not defined” etc?

If yes, try this:

  1. Stop Odoo

service odoo stop

  1. Check the database for ir_attachments table entry
> psql -Uodoo
> select id, create_date, store_fname, datas_fname from ir_attachment where datas_fname like '%.js%';
  1. Delete records that you found like “web.assets_*.js” from ir_attachments table.

delete from ir_attachments where id in (… , … )

  1. Restart Odoo

service odoo restart

  1. Open Odoo on browser and check

Thanks @angshuonline for your quick reply, here is what happened, The installation process went on smoothly and all was running smoothly. then suddenly odoo stop when I try to start odoo I get the error below

[root@meds stephen_otieno]# sudo service odoo start Starting odoo (via systemctl): Job for odoo.service failed because a configured resource limit was exceeded. See “systemctl status odoo.service” and “journalctl -xe” for details. [FAILED]

[root@meds stephen_otieno]# journalctl -xe

Jul 08 09:14:01 meds odoo[2855]: odoo.cli.main() Jul 08 09:14:01 meds odoo[2855]: File “/usr/lib/python2.7/site-packages/odoo-10.0.post20190619-py2.7.egg/odoo/cli/”, line 64, in main

the full log is here pastebin

Can you check the resources in the system?

  1. Do you have enough space & memory?

df -h

  1. Whats your machine’s configuration? and how many components have you installed (e.g. EMR, LAB, ERP etc etc)

  2. Can you stop any other existing service, start odoo and see

service bahmni-lab stop
service bahmni-reports stop
service dcm4chee stop
service odoo start

My server in 15GB RAM, have tried to stop other service and start odoo but still get the same error.

How can I uninstall and reinstall odoo alone

(use the --only option of bahmni installer)

> service odoo stop
> yum remove bahmni-erp
> rm -rf /opt/bahmni-erp

backup the odoo database, and drop the db (not necessary or desirable all the time, but lets do this to ensure that everything is clean)

> psql -Upostgres
> drop database odoo

now, install ERP again

bahmni -i local --only bahmni-erp install


A new version 0.92-118, is available now from our s3 repo. You can download from here


  1. BAH-848: Bahmni EMR rpm installation does not create bahmnicore properties file
  2. BAH-844 Integration between MRS-ERP fails if Lab Component is not installed
  3. BAH-841 Discount Amount is not calculated in Journal Entry while validate Invoice - fix for the Net amount calc
  4. BAH-847 - “Default” implementation installation shows an existing customer and an order associated

The same build is available now at product-qa08 env

Please keep up the good effort on testing. Much appreciated.

1 Like

I have followed the steps and I Am getting this error

Traceback (most recent call last): File “/usr/bin/bahmni”, line 11, in load_entry_point(‘bahmni==0.1’, ‘console_scripts’, ‘bahmni’)() File “/usr/lib/python2.7/site-packages/Click-7.0-py2.7.egg/click/”, line 764, in call return self.main(*args, **kwargs) File “/usr/lib/python2.7/site-packages/Click-7.0-py2.7.egg/click/”, line 717, in main rv = self.invoke(ctx) File “/usr/lib/python2.7/site-packages/Click-7.0-py2.7.egg/click/”, line 1137, in invoke return _process_result(sub_ctx.command.invoke(sub_ctx)) File “/usr/lib/python2.7/site-packages/Click-7.0-py2.7.egg/click/”, line 956, in invoke return ctx.invoke(self.callback, **ctx.params) File “/usr/lib/python2.7/site-packages/Click-7.0-py2.7.egg/click/”, line 555, in invoke return callback(*args, **kwargs) File “/usr/lib/python2.7/site-packages/Click-7.0-py2.7.egg/click/”, line 17, in new_func return f(get_current_context(), *args, **kwargs) File “build/bdist.linux-x86_64/egg/”, line 79, in install File “/usr/lib64/python2.7/”, line 542, in check_call raise CalledProcessError(retcode, cmd) subprocess.CalledProcessError: Command ‘ansible-playbook -i /etc/bahmni-installer/local all.yml -vv --extra-vars ‘@/etc/bahmni-installer/rpm_versions.yml’ --extra-vars ‘@/etc/bahmni-backrest.conf’ --extra-vars ‘@/etc/bahmni-installer/setup.yml’ -t bahmni-erp’ returned non-zero exit status 4

We have not come across this error. Googling results in this

What version of CentOS are you using?