Align checkboxes horizontally in HTML form

I am building an HTML form. In the preview the check boxes are horizontally aligned but in the form itself the boxes are vertical. How can I get the desired result?

Can you send a screenshot?


Thanks for your reply Ellen. I followed advice given on this post (Why does an HTML form look different in the patient dashboard?). And I’ve tried many other things but nothing is working.

As you can see in the form on the UI, the check boxes are aligned vertically, which takes up a lot of space. In the visit note, location of headache is repeated with each check box ticked. Is there a way to have multiple answers lined up alongside one question? Mike

@mikejg are you able to reproduce it here?

@dkayiwa I cant login with my OpenMRS ID, and I’m not sure what you’d like reproduced?. I suspect it would be easier to set up my forms with the XForms module, which I uploaded, but it wont start. Can you confirm its not compatible with my installation, or what I can do to get XForms started: OpenMRS Information Name Value System Date 2017-04-25 System Time 09:58:56 OpenMRS Version 2.0.1 Build f2ddde Host Name mikegordon.lan Module Information Name Value Local repository /Users/default/.OpenMRS/modules Atlas Module 2.2 Form Entry App Module 1.3 Reporting 0.10.6 Metadata Sharing 1.2.2 ID Generation 4.4.0 Allergy UI Module 1.6 EMR API Module 1.18 Registration App Module 1.6 HTML Form Entry UI Framework Integration Module 1.6.1 App Framework Module 2.9 Reporting REST 1.6 Reference Metadata Module 2.5.0 Metadata Mapping 1.2.1 Custom Branding 0.2 Not Started Admin UI Module 1.2 OpenMRS UI Framework 3.9 Reference Application Module 2.5 Metadata Deploy 1.7 App UI Module 1.7 XForms 4.3.4-SNAPSHOT Not Started Reporting Compatibility 2.0.2 HTML Widgets 1.7.2 Serialization Xstream 0.2.12 HTML Form Entry Designer 0.6.1 Not Started Address Hierarchy 2.10.0 Registration Core Module 1.6 HTML Form Entry Extensions for OpenMRS 1.9 Module 1.7 Core Apps Module 1.11.1 Event Module 2.5 Provider Management Module 2.5.0 Chart Search Module 2.0 Calculation 1.2 Appointment Scheduling UI Module 1.4.0 Open Web Apps Module 1.6.3 FHIR Module 1.6 HTML Form Entry 3.3.0 UI Commons Module 2.1 Rest Web Services OMOD 2.16.e045a4 Appointment Scheduling Module 1.7.0 Legacy UI Module 1.2.3 Data Exchange Module 1.3.2 UI Library Module 2.0.4 Reference Demo Data Module 1.4.3

Can you paste the contents of the error log at That will help us figure out why some of your modules are not starting.

Thanks @dkayiwa. I’ve pasted my server log (is that what you’re after?) here

Is this all you have in the log file? What is the file name?

@dkayiwa that is everything in my server log. If you mean the name of the HTML Form file, it’s Headaches. Could you see from the log file why my modules wont start? I’m having a number of issues in different areas and it might help if I could get the modules started?

@mikejg do you have any reason why you did not take the easier approach of using the released reference application version 2.5?

I believe I downloaded the application as seen on the screenshot from the following page

After that I’ve uploaded modules, some of which could be started, others not for reasons unknown to me. Is this not the application you’re referring to? I would love to get on with creating some forms and testing them with reports but I keep running into roadblocks.

That looks correct. Did you try out the standalone version of the reference application?

To be honest, I tried it, and other versions but reasons I cant recall couldn’t get them going.

Can you try the reference application 2.5 standalone and tell us what exactly happens?

OK, I cant do it right now so I’ll have to get back to you on that later today.

I managed to start the process and this is exactly what happened. I downloaded reference application 2.5 standalone, opened the jar file, selected demo mode, the app attempted to start on Tomcat port 8081 and MySQL port 3316. The processes started and then froze before completion, with the last log lines being: Caused by: java.lang.ClassNotFoundException: at at java.lang.ClassLoader.loadClass( at java.lang.ClassLoader.loadClass( at java.lang.Class.forName0(Native Method) at java.lang.Class.forName( at com.mysql.jdbc.MysqlIO.createSocketFactory( … 19 more The full log is at:

Which operating system do you have?

I have a mac OS X

Do you have time to come on IRC for a more interactive walk through? Am logged in there as dkayiwa

Using standalone gives me the same result. Has anyone managed to align check boxes in the forms used in the patient dashboard?