Why the SDK can not find this plugin

Hi, all, I’m using the OpenMRS-SDK to install the OpenMRS Platform, but it reported this error. Can anyone help me fix it? Thank you very much!

It reports this error when I chose the MySQL 5.6 and above in SDK docker…

I am having the exact same problem.

1 Like

@d404d and @navareth sorry for the error! Kindly, Is it okay to use pastebin to share the entire error log?

There you go: https://pastebin.com/0Mdmf7P2

Basing on the logs shared above did you forget to select the database you would like to use?:

@navareth I would suggest you select option 1 which is 1) MySQL 5.6 and above (requires pre-installed MySQL 5.6 and above) if you installed Mysql or option 4 if you are running PostgreSQL

Not at all, I’m just using “tee” Unix command to redirect console output to a file. That’s why it doesn’t show any user input :smiley: By the way, I’ve chosen 2 which is printed by the script later on

Kindly try option 1

That of course works but that’s not the point. We’re just reporting that option 2 doesn’t work as of right now :slightly_smiling_face:

1 Like

Yes, I have tried this option, but report this error. The following is what I enter

The distribution requires MySQL database. Please specify database uri (-DdbUri) (default: ‘jdbc:mysql://localhost:3306/@DBNAME@’): jdbc:mysql://locallhost:3306/openmrs

Please specify database username (-DdbUser) (default: ‘root’):

Please specify database password (-DdbPassword):

good question! the database name has default root just press enter without entering/typing anything. The password to be used is the password to root you created while installing Mysql.

By the way,I have make sure the mysql can be used

Hope you installed Mysql and you remember the password to root

It would be helpful if you could include the full output of what you are running in pastebin.com rather than a screenshot of a portion of the output, as @navareth did above. There isn’t really much information in that screen shot to enable anyone to help you diagnose what’s going on.

Would you be able to open a ticket for this in the SDK project? That definitely seems like some kind of bug.

There it is pastebin. Thank you

There’s a typo in the URL you are using (it needs to be localhost rather than locallhost). jdbc:mysql://locallhost:3306/openmrs should be jdbc:mysql://localhost:3306/openmrs (note that the @DB_NAME@ placeholder is probably also usable here, e.g., just accept the default). Sorry I didn’t notice the typo before.

1 Like

PS another workaround for this is to create the Docker image manually and use option 3. Something like this:

docker run --name mysql-5 -e MYSQL_ROOT_PASSWORD=<choose password> -e MYSQL_USER=openmrs -e MYSQL_PASSWORD=<choose password> -p 3309:3306 -h mysql-5 --restart unless-stopped -d mysql:5.6 --character-set-server=utf8 --collation-server=utf8_unicode_ci

Sorry, although I fixed the typo error, there is still an error here pastebin.

Besides, I also tried to use the default value for the whole option except the database password, and the error report is here, pastebin