Why doesn't my installation of Plaform look like demo.openmrs.org?

Dear OpenMRS Community, I am trying to implement the OpenMRS. I have been able to install it and when loading this is what it shows

When looking at the demo, there are more options that are shown, example: capture vitals, active visits and other options.

My question is, in order to have the same for my implementation is it necessary to installing modules? And if so, how do I do that?

Thank you in advance! Any help is appreciated.

Dear @memedhe, welcome to the OpenMRS community.

You have installed OpenMRS Platform. Now, to get the functionality you’re looking for, you will need to install the Reference Application modules. For information about the Reference Application see… https://wiki.openmrs.org/display/docs/Reference+Application+2.3

To download Reference Application go to… http://openmrs.org/download/ and click “Download Reference Application 2.3.1 Modules & Data”. Unzip the files and drop them into the modules directory.

Hope this helps.


@memedhe this might be helpful, https://en.flossmanuals.net/openmrs-guide/

Thank you for your reply…I did try to do as you told. Now it’s showing errors when trying to upload Modules

Is there a better way to include Modules besides by uploading each module one by one. How does this work? Thanks!

Every module that I am uploading it is requiring to install even more modules

Yes, you should copy all the .omod files to .OpenMRS/modules and restart Tomcat. The location of the .OpenMRS directory depends on your install, but you should be able to find it on the system information page (it’s usually something like /usr/share/tomcat7/.OpenMRS).

Hello Pascal, should I paste all the .omod files to this path: C:\Application Data\OpenMRS\modules Or should they be pasted somewhere in a path where the Tomcat is installed?

Thanks in adavance for any help!

The only other folder with the modules folder in the path where Tomcat is installed is: C:\Program Files\Apache Software Foundation\Tomcat 6.0\work\Catalina\localhost\openmrs\org\apache\jsp\WEB_002dINF\view\admin\modules

I am not sure where the .omod files should be put. Thanks!

The location will not be in the Tomcat work directory. The modules directory will be in the same directory as the openmrs-runtime.properties file.

I’m not sure of the exact location on Windows, but it could be something like {USER_HOME_DIR}\{APP_DATA}\OpenMRS\modules.

If you installed some modules via the UI, there should already be some .omod files in the directory. Perhaps search your filesystem for “.omod”?

Lastly, if you look at the Tomcat log while OpenMRS starts up, it should give you the location of the openmrs-runtime.properties it is using (including the path), which should help you find the modules directory.

1 Like

To answer your questions on the other thread:

I’ve tried uploading the Modules one-by-one from the ReferenceApplication folder downloaded from the openmrs webpage. Just some Modules are uploaded successfully and it crashes after a certain amount of Modules uploaded.

Uploading the RefApp modules one by one is not the correct way to install them.

I’ve also tried to copying the whole folder with the modules to the Application Data folder in C:/. That doesn’t seem to be working either.

What is the full path of the modules directory you put the .omod files in? Is there a openmrs-runtime.properties file in the same directory as the modules directory?

Is there a way to safely and successfully incorporate modules to OpenMRS and how? If there’s somebody who has encountered the same difficulties how to solve them?

Yes, copy the .omod files to the correct modules directory and restart Tomcat. Once you’ve done this, visit the module management page and let us know what it looks like.

If you’re not sure what the correct modules directory is, look at the value of Local Repository in the Module Information section of the system information page.

1 Like

2 posts were split to a new topic: PermGen space error when restarting Tomcat