Why does Platform 1.11 installation hang at "update the database"?

Platform Version: Platform 1.11.x

Question: Hello, I am trying to run Platform 1.11.x on my Mac OSX (10.10.5), Java version 1.6, Maven 3.2.5, MySQL 5.1.73.

I pulled the latest code, and ran maven clean install successfully.

I then executed mvn jetty:run (I had to add a openmrs-runtime.properties file with MySQL root username/password to the webapp directory, and add an empty openmrs schema in MySQL), and reached the “Update the database” step where it stopped at 49% with this output:

Updating database tables to latest version (288/582): Author: wyclif Comments: Dropping foreign key constraint on concept_name_tag_map.concept_name_tag_id Description: Drop Foreign Key Constraint Number of actions completed so far: 719

Here is the console log until the point where bean creation errors occur: http://pastebin.com/BzHKwQUm

I also tried a fresh install after dropping the database, with the same result.

Screenshot of installation wizard attached.

It’s a very strange behavior. Does the same thing happen when you use openmrs-sdk:setup-platform? For the version, use 1.11.4-SNAPSHOT. The SDK also uses jetty with the difference that it runs on the h2 database by default. I’ve just checked and it works correctly for me. If you could try that it would help to narrow down possible causes of your issues.

It works with the opemrs-sdk:setup-platform, using Java 1.7 (failed with 1.6). Thank you!

I had also tried Java 1.7 using my original installation method without success.

Just wondering what my options are now?

  1. Run 1.11.x with an h2 database, is this possible?
  2. Only use openmrs-sdk:setup-platorm: what if I need to modify and test code in the 1.11.x branch?

Okay, thanks for checking the SDK. It might be an issue with MySQL then. Could you please try upgrading your MySQL to some more recent version? I’m using MySQL 5.6.12 for development across all OpenMRS versions so you could try that version.

Java 1.7 is required by SDK. OpenMRS 1.11.x should run just fine on Java 1.6. And to answer your other questions:

  1. You should not be running 1.11.x with an h2 database for anything other than development. Many modules do not support the h2 database at all so you will not be able to install them.
  2. We’ll shortly add a feature to enable using the SDK for locally built versions of openmrs-core. It is actually possible at the moment, but not supported so I will not explain how.

I upgraded to MySQL 5.6.12 and got the same error installing 1.11.x