where are the icons?

(Moses Mutesasira) #21

the proble seems to be selecting out the right verios of the modules

(Moses Mutesasira) #22

can you now be more specificon which errorrs you get after loading the reference application module and the required modules…you can please attach a screen shot here

(Hamed Abulfatih) #23

now i copied all the modules from the standalone version as they must work! but still a lot of modules would not start. i wanted to start the emr module and it gives me the error Error

  • while trying to start module
  • Unable to update data model using liquibase.xml. Module: EMR API Module
(Hamed Abulfatih) #24

you know I think all the errors are because of Java!

(Moses Mutesasira) #25

what version of EMR API are you running and on which openmrs core version are you running??

(Moses Mutesasira) #26

i dont think so. its caused by version incompatibilities between modules and the core

(Moses Mutesasira) #27

Some times that’s caused by a disorganized database, first option would be to drop the whole database, and build it afresh.

if that fails ,then we go to upgrading the core version

(Hamed Abulfatih) #28

Success!!! I managed to get it running! I deleted all java cached files, then i deleted all openmrs cached files and stopped all services (apache, mysql and tomcat), i restarted the computer and then i went to the stand alone package 2.9 and copied all the modules from there into the openmrs module folder and started everything and it took some time but everything is working! I cannot believe it! after 2 weeks of trying and just in time as I am supposed to start customizing this Saturday! Thank you very much for the help and time for reading and replying! and thank you God! I hope it does not crash! I will not change anything now!

1 Like
(Moses Mutesasira) #29

thats great, you can now remove the modules you dont need now , but make sure the you leave in the core modules required ie, referenceapplication , EMR api , Coreapps etc

(Moses Mutesasira) #30

:grinning: haha , i understand the hustle you’ve gone through