what versions of tomcat and Mysql are needed to install reference application 2.7?

what versions of tomcat and Mysql are needed to install reference application 2.7?

Hi @hossam

You can install MySQL 5.6 or MySQL 5.7 and Tomcat 8.x for the reference application 2.7. Hope this updated versions will help you.

1 Like

Thank you! will try it today

@suthagar23 I found issues with MySQL 5.7(on my Debian System) i’d encourage @hossam to use 5.5 or 5.6

@tendomart what issues? MySQL 5.7 is supposed to work well with the latest releases of the openmrs platform and reference application.

When i try to deploy the war file… It doesnt upload… Instead it says “thos site cannot be reached” I already added the roles tomcat, admin, manager, manager-gui to users.xml @dkayiwa can you please help me with this?

@dkayiwa posting requests to the database. So i downgraded back to 5.6 which works just fine for me.

@hossam can you undeploy the war file from Catalina and localhost folders

clear the Cache and restart tomcat and redeploy the war file. some times those errors come because the server is trying to bootstrap from old files.

@tendomart simply saying “posting requests to the database” would take a magician to know what exactly was going on.

1 Like

Unfortunately i did not forward the problem on Talk.