What is the Module id

Hallo guys Need some help here what does it mean to consult your module ID and what is the module ID

and am failing to access http://localhost:8080/openmrs this site whenever i go there to check my progress this is the error it gives

Access Error: 404 – Not Found

Cannot open document for: /openmrs @omrsadm @odorajonathan @jwnasambu

@suubi7 , sorry for the above error. Can you describe what your trying to do and the steps your following ??

I am trying to run OpenMRS locally I have executed the following command

mvn clean install openmrs-sdk:run -DserverId=your_server_id_here

and am trying to go to htttp://localhost:8080/openmrs but the site is throwing that error

Have you setup a server and also created a module ??

Yes i created a server but the module part

Have you tried to run the server alone ??

How do you do this?

try running mvn openmrs-sdk:run from any other directory and check if you have any set-up servers

Yes i have and and i have to setup servers

C:\Users\Joel> mvn openmrs-sdk:run [INFO] Scanning for projects… [INFO] [INFO] ------------------< org.apache.maven:standalone-pom >------------------- [INFO] Building Maven Stub Project (No POM) 1 [INFO] --------------------------------[ pom ]--------------------------------- [INFO] [INFO] — openmrs-sdk-maven-plugin:3.13.6:run (default-cli) @ standalone-pom —

You have the following servers::

  1. 2
  2. 1

Which one do you choose? [1/2]:

go ahead and run , it . and deply your module manually

I have and still waiting for the command to end.

meanwhile this was the error from before after inserting this command

mvn clean install openmrs-sdk:run -DserverId=your_server_id

and i have gone through my systems environment settings and my JAVA_HOME is set but things are not working.

@suubi7 how far with the command Moses told you to run? Are you able to run an OpenMRS instance?

Oh @suubi7 its mvn openmrs-sdk:run and not mvn clean install openmrs-sdk:run -DserverId=your_server_id

All worked out well

Okay thank you