Was unable to run the Bahmni Docker Getting Started Guide on Mac (Intel and M1)


I spent a few hours trying to set up Bahmni on Docker using my Intel Mac and my M1 Mac without success. This is for Bahmni Lite although I attempted both also with no succes. This was the article I was using: https://bahmni.atlassian.net/wiki/spaces/BAH/pages/3117744129/Getting+Started+Quickly+with+Bahmni+on+Docker#Running-Bahmni-Lite

The M1 Mac failed at the install attempt. I assume that Bahmni’s Docker image has yet to be made yet. Found this closed issue (BAH-2568) with another connected issue that appears to be still being worked on (BAH-2505). It hasn’t had any activity since last month. Is there any way to help work on finalizing the fix?

On my Intel Mac using Docker (which should be supported), I was able to get it to no errors but I get a 404 when trying to route localhost to a supported route (i.e localhost/openmrs). Going to “localhost/” just gave me text saying “It worked!”

This is my docker instance:

To get to no errors and all greens for each image I had to change the config file to change proxy-1 from 80:80 to 79:79 because port 80 was already being used. I do not know if this contributed to my 404 issue.

I am not sure if I was doing something incorrect or if this is an issue seen before (could not find anything similar on the forums or Jira) from my research.

Thanks, Andrew Rodebaugh

I was able to run Bahmni on Mac M1. See these steps (only required for crater. other stuff should work without making changes) – section: Run Bahmni Docker on Apple Silicon Mac M1 machines:


For your intel machine, all images seem to be up and running. If so, try accessing OpenMRS first (it usually takes about 5-10 mins on some machines to come up first time. A restart of docker containers can also help move it along). See this (Bahmni UI keeps loading): https://bahmni.atlassian.net/wiki/spaces/BAH/pages/3119710209/Common+Troubleshooting+Guide+docker#Bahmni-UI-keeps-on-loading

You can check OpenMRS log to confirm its up and running. (use the run-bahmni.sh script, it can show you a quick command for seeing OpenMRS container logs).

Note: I am on leave till second week of April, so might not see your reply quickly. Hopefully someone else can follow-up and reply.