vbox 0.90 Error on Windows 10

Host OS Windows 10. Bahmni vbox 0.89 was running perfectly fine. vbox 0.90 gives error Has anyone seen this error

WinVerifyTrust failed with 0x8 () on ‘\Device\HarddiskVolume3\Program Files\Oracle\VirtualBox\VBoxHeadless.exe’ 239c.194c: Error -22919 in VBoxHeadless! (enmWhat=1) 239c.194c: WinVerifyTrust failed on stub executable: WinVerifyTrust failed with hrc=Unknown Status 0x8 on ‘\Device\HarddiskVolume3\Program Files\Oracle\VirtualBox\VBoxHeadless.exe’ 204c.2fa0: supR3HardNtChildWaitFor[2]: Quitting: ExitCode=0x1 (rcNtWait=0x0, rcNt1=0x0, rcNt2=0x103, rcNt3=0x103, 523 ms, the end); 17a0.17a4: supR3HardNtChildWaitFor[1]: Quitting: ExitCode=0x1 (rcNtWait=0x0, rcNt1=0x0, rcNt2=0x103, rcNt3=0x103, 1455 ms, the end);

Hi @ramashish, How did you get v0.90 vbox?? Did you directly download the v0.90 box or ran the vagrant box update command to upgrade to latest version??

I tried both, i.e. update and direct download.

I was running 0.89 and vagrantfile had config.vm.box_check_update = true line so I assume that it checked for the updates and downloaded the updated box first time but that didn’t work.

So I downloaded the box directly, renamed it to package.box and changed vagrantfile accordingly to point to the folder.

But that didn’t work either.

So I removed projects\bahmni folder. Removed the vbox RPMs. Freshly cloned bahmni-vagrant folder but that also did not work.

All options gave the same error mentioned in this thread.

Hi @ramashish, I tried the fresh vagrant setup for v0.90 Bahmni. I followed the steps mentioned in Bahmni Virtual Box wiki page and I don’t see any issue with Virtual Box. Mine is Mac.

I think the above issue that you are facing is specific to Windows machine Virtual Box. Please check this link for the workaround.

Upgrading Vigrant to 2.0.1 and VirtualBox to 5.2.4 resolved the issue. Host OS Windows 10 (OS Build 16299.125).