Uploading & starting all modules in Reference Application 2.3

after finally deploying OpenMRS war file to Tomcat, It was only uploaded with Web REST module. So I stopped Tomcat and I copied the modules of reference application 2.3 into the directory: ApplicationData/OpenMRS/modules. When I restarted Tomcat, It took forever to start and couldn’t load the OpenMRS page. I tried uploading the modules one by one. It worked with some modules but Tomcat got stuck again with some other modules. How can I smoothly upload and start the modules in OpenMRS enterprise? and how long should I leave tomcat before I start suspecting something’s wrong?

Now I’m starting to realize why you used parentheses there @arbaughj :slight_smile: “I hope you can get over this (last) hurdle.”

Hi @hossam. I’m sorry to hear you are still having problems.

What error did you get when Tomcat quit working? There is a long file that has detailed error messages. On Linux it’s catalina.out, I don’t know what it is on Windows. Anyway, that might give you a clue on what the problem is. It would also let you know if it’s busy working on something or if it’s hung. It should load within 15 minutes if all goes well. My system normally takes 2-5 minutes for Tomcat to start OpenMRS. When adding the modules for the first time, it takes longer.

I would guess that you might not have enough memory allocated to your Tomcat. Did you increase the memory from default? If not, here are some pages with instructions of how to set that… https://wiki.openmrs.org/display/docs/Troubleshooting+Memory+Errors https://wiki.openmrs.org/display/docs/Performance+Tuning

I think you can set this through the tray icon in Windows, but I haven’t done it in so long, I forget.

Hopefully this helps.

1 Like

In windows I found the log file in the directory /tomcat6/logs. It’s called catalina(date).log. but it’s not in realtime though like it is in standalone.

Tomcat used to take hours to start OpenMRS and fails. I added those parameters to Tomcat: and now all is good. Again…Thank you!!

1 Like

@hossam, I’m glad you’re up-and-running! It was a pleasure to be able to help you.

That’s a nice screenshot on setting the memory. Maybe you would consider updating the documentation and adding that and some instructions to one of the wiki pages mentioned above.


Ok it’s done.

1 Like

Thanks for contributing back to the OpenMRS community!

it’s the least I can do!