Upgrading to enterprise 2.4 ref app 2.11

Hi, I’ve been having troubles upgrading from enterprise 2.3… ref app 2.10… to ent. 2.4 and ref app 2.11 I’ll need to move the database to the intended implementation. Deploying the openmrs war file isn’t much of a problem as I understand that. The problem comes when I want to deploy it using a ready database, as against creating a new one from the deployment. I receive: ??? Error executing sql: create user? @ local host identified by ? -could not create connection to database server. Attampted reconnect 3 times. Giving up??? OS: window 10, server; Xampp. Would appreciate some help. Thanks

1 Like

Thank you so much for sharing this @yusufny, we haven’t actually heard much feedback on the 2.4 platform release or the 2.11 RefApp release yet, so it’s good to hear from you.

@dkayiwa @gcliff @sharif @mozzy might you be able to help Yusuf?

Thanks @grace.

This happens for various two reasons

  1. First, your MySQL might have been disabled (some MySQL distributions do that by default for security reasons). Since JDBC uses TCP/IP protocal, you must enable it. To see whether or not TCP/IP Address is enabled, you can do: just on windows type

$ telnet localhost 3306 Trying 127.0.0.1… Connected to localhost.: this means that MySQL is listening on port 3306.

  1. Secondly: you may have in-correct mysql user permissions. You need to check whether you have provided similar MYSQL credentials(password and User), these would need to collerate to the same credentials you provided at hand unless you changed them. Feel free to share the full log using pastebin.com as we can look into it thanks
1 Like

Thanks @sharif. Would use the guide to see where I got it wrong and revert.

Can you share the guide you are following but mostly sharing your logs the better

Hello, @sharif would be trying your options out now. But here is a further update: So far, I tried a clean installation (from scratch) using the 2.4 platform and both 2.10… and 2.11 refapp. It doesn’t load all modules. The whole ui is gone. I could access the administrative Page. When I checked the modules a tone load weren’t started. I tried starting as a batch and individually… same result. Again, os is windows and server xampp.

Can you paste the full server side log at pastebin.com as @sharif advised ?

1 Like

hello, i discovered the error. xampp server 7.4.6-vc 15 didn’t meetup with the necessary requirements ( sql ver…). so i got xampp ver. 8.0.0.2 vs16. with this i could run and deploy openmrs platform2.4 and refapp 2.11. the only issue here is that a couple of modules wouldn’t load. i check their dependencies; downloaded them and uploaded them yet still. Also i tried deploying openmrs to use an initial database; but only received errors. i know i must be doing something wrong. attached to this will screen shoots and the link to the logs. openmrs log - Pastebin.com (openmrs logs)

the first image above is when i try deploying the war file and directs it to read from a previous openmrs database i exported. the subsequent images are for the error in loading module

Drop the database, delete the runtime properties file, and run the setup wizard again.

morning, seems i was calling for lots of shots same time. please bear with me. would love to follow it systematically. firstly, fresh installation of platform 2.4; refapp 2.11; not all modules loaded. i downloaded the dependencies (module versions required for them to run) and manually added them. i noticed that when i rerun the server to load; 6 out of 11 required modules automatically gets deleted and the webapp behaves same as initial. i tried downloading from the interface, same. here are list of the modules that behave as such: coreapps-1.11.1 emrapi-1.18 emrapi-1.29.0 reporting-0.10.4 reporting-1.15.0 reporting-1.19.0 any directions towards getting around this please. images are attached and openmrs logs link below

Just download the 2.11.0 addons from here: Download OpenMRS | OpenMRS and drop them in platform 2.4.0

FWIW, https://qa-refapp.openmrs.org/ is already running platform 2.4.0

1 Like

thanks, will dojust that and update

I decided against xampp server and use a more professional setup (Mysql and tomcat stand alone). Deployment went smoothly, except for… I can find my openMrs folder that was suppose to be in …appdata/…/roaming/openMrs. Please need some support. Thanks

Can you share the tomcat log via pastebin.com?

thanks @dkayiwa for always being there. here goes the log link: https://pastebin.com/0bkKCGiX

Does not look like the full log.

hello, i checked, that was all for the catalina.2021-01-08 log. i have also attached the manager.2021-01-08 log. this is the link: manager.2021-01-08 - Pastebin.com

Check for a property named Local repository at your equivalent of this: https://qa-refapp.openmrs.org/openmrs/admin/maintenance/systemInfo.htm