Upgrade from OpenMRS 1.6.3 to 2.7.2

Hi, I have been using OpenMRS ver 1.6.3 since 2013. I want to upgrade to the latest version. Kindly help me out with the procedure

Kindly take a look on how you can upgrade openmrs https://wiki.openmrs.org/display/docs/Upgrading+OpenMRS, Again you could also try to give more details of what you are trying to upgrade

Thank you so much @sharif for coming to my rescue. I have been trying to edit my OpenMRS to enable me to configure Facility IDs but there is no setting option for me to do this.

Attached herewith, image screenshot of my OpenMRS Admin section

(upload://efjveeCPCSYauPsfN3p7eStE2E1.jpeg)

Thank you.

1 Like

Are you still using the BIRT module for anything?

Are you still using BIRT module as said above by @dkayiwa

FYI @moses, OpenMRS 2.7.2 ain’t the latest version

2 Likes

Okay, Thanks for the hint.

How do I configure Facility Unique ID? So that all the patient in that facility will be tracable to the configured Facility Unique ID.

Thank you.

Yes, but if it will not be useful for the upgrade, I can do away with it.

Thanks in anticipating your candid support.

You are going to first upgrade the database before dealing with the modules.

  1. Do a complete database backup and keep it some where safe.
  2. Stop Tomcat.
  3. Remove all modules from the modules folder on the file system and keep them some where else.
  4. Delete the openmrs.war file and openmrs folder from the tomcat webapps folder.
  5. Download and put the war file for OpenMRS platform 2.3.1 in the tomcat webapps folder
  6. Start Tomcat and go to the browser to follow the database update process.

The database update process is most likely going to give you errors. But share them using pastebin.com and we shall guide you in regards to how to deal with them.

1 Like

Thank you so much. I will definitely reach out to you if need be.

Hi @dkayiwa, Thank you once again for your support. Like you said, I ran into a problem but could`t fix it.

I tried to upgrade my OpenMRS from 1.6.3 to 2.3.1 This is the message I received: FAIL - War file “openmrs.war” already exists on server

I couldn’t do anything after that, I tried to uninstall, it doesn’t work out anymore…

Thanks, Moses

can you check your tomcat web app folder to make sure that you don’t have a an openmrs.war file existing before trying to upload a new one ie delete the current openmrs.war file before trying to upload a new one

1 Like

Thank you so much @herbert24, I will give it a try right away and get back.

Thank you everyone for your contribution, my OpenMRS is up and working.

1 Like

you could add your solution here to help others