Updating openmrs database during installation

Hello folks;

I am trying to setup a reff app server 2.11.0-SNAPSHOT running on platform 2.4.0-SNAPSHOT however during the installation i run into this error

yet the file is existing

Any reasons why this file is not being read during the updating of the database ?

@wolf @ibacher @dkayiwa

Are you able to do a fresh setup of the platform?

@dkayiwa not really , am running into the similar error during the installation

Personally am also running into same issue, however deleting AppData/cache didn’t save me , though still figuring out, but it seems the problem is from liquibase updates no up to date

Can you share the full log?

1 Like

Sorry for late reply Here is the log https://pastebin.com/M5Jxx30i

1 Like

When did you last run this setup successfully?

Have actually run this set up like 2 hours ago

Successfully? And then after two hours it fails?

No please i have not run it successfully, rather after running it i encountered similar error , in other words i couldn’t access it via UI, the same screenshot above is the same am getting also

Then am confused by your reply to the above.

I Haven’t run it successfully so fur

@gcliff i remember as if you successfully set this up a couple of weeks ago. Correct?

yes @dkayiwa

i have just run the platform server that i set up a few weeks back and it works fine

dont know why the currently set up platform servers ain’t responding appropriately

1 Like

Great @gcliff, can you try again with latest platform atleast with latest changes , just want to be sure whether we get either same or different logs

@sharif when i try with the latest platform and its changes i get the first errors above

1 Like

Try to run a specific version of the sdk with: mvn org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:3.13.6:setup

And: mvn org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:3.13.6:run


@dkayiwa i have run the first command and its shows 2.3.2-SNAPSHOT as the latest platform version snapshot

Choose: 7) Other...

hello @dkayiwa i have run in to this error which is prohibiting the setup

i have droped the database and deleted the runtime properties file but still encountering the same error