Unstable builds of Reference Application 2.3 module

Hi all !

I am working with a fork of Reference Application module based on tag referenceapplication-2.3.

On the OpenMRS repo, the referenceapplication-2.3 tag doesn’t build. I think it almost never did.

To make it build, it is necessary to patch the pom.xml by adding dependency on ‘emrapi-api’ and ‘emrapi-api-1-11’ such as added by @raff on the master in commits a89b3f0 and 50f6d1d. (see post Suddenly can’t build the Reference Application module)

This worked fine for the last few months.

But now the module doesn’t build anymore: test failures on OMOD: http://paste.ubuntu.com/15400144/ without changing anything in the code.

That is a major problem for us to have this module suddenly stop building.

1/ Is the dependency on <distro.version>LATEST</distro.version> the reason of the problem ?

2/ Could we depend on <distro.version>2.3</distro.version> instead ?

Once a solution is found, and we are not depending on SNAPSHOT versions, I guess we could do as @darius suggests:

just to provide people with a working source code of this Reference Application module 2.3

OR… are we close to releasing 2.4 ? (so then skip 2.3)

Hi @mksrom,

I don’t have a good answer here; this is the same issue that @mogoodrich has brought up recently (though I can’t find the thread).

Basically, we started taking an unsafe shortcut a few years ago, by having a bunch of modules all share their dependency versions by importing the distro pom, but it seemed to not cause any real-world problems for years, though recently more issues have come up.

So, yes, the dependency on distro.version=LATEST is the problem, because it will try to build against always-incrementing versions of other modules. If setting it to 2.3 solves the problem, then go ahead and do that.


just for reference, I believe this is the thread you were referring to?

OK. Well, I tried to set the distro.version to 2.3 and it doesn’t solve the problem. After reading @mogoodrich thread you points me to, I understand now why.

Thanks. I’ll follow up there.

1 Like