Unknown system variable default_storage_engine


(Herbert Yiga) #1

i am trying to setup sdk,but after running mvn openmrs-sdk:run, i get this error https://pastebin.com/6njUDdaf .i have tried to look for some online solutions but they werent of help.Any suggestion?


(Samuel Male) #2

Not sure as to why this is happening, but it could be with dependency incompatibility.

Don’t you wanna add more info? In the first place, whats the version of yr MYSQL server? And what does this return

mysql> show variables like "%storage%";

(Daniel Kayiwa) #3

This was fixed in platform 2.0 as you can see here: https://issues.openmrs.org/browse/TRUNK-4800

So you can either use a higher openmrs platform version or downgrade your mysql.


(Herbert Yiga) #4

thanks @dkayiwa,@samuel34 i am going to get back to you after doing that


(Herbert Yiga) #5

@dkayiwa as installing the sdk,this is what i have for msql server version(Server version: 5.1.53-community-log MySQL Community Server (GPL)
) and i have tried the follwoing versions of distribution

(1)Reference Application 2.9.0-SNAPSHOT (2) Reference Application 2.8.0 (3) Reference Application 2.7.0 (4) Reference Application 2.6.1 (5) Reference Application 2.5 .

As you had suggested that i use a lower version of the database,i think i am using a lower one,and i have tried using the Reference Application 2.9.0-SNAPSHOT as the higher version of openmrs platform but still it brings out the same error!!! could it stil be version incompability


(Samuel Male) #6

What does the above query return?

Btw, try using 5.7.* @herbert24


(Herbert Yiga) #7

it returns Variable_name=storage_engine and value=MyISAM


(Samuel Male) #8

The version of mysql server yr running is incompatible with refApp 2.x.

Upgrade to at least 5.7.17.


(Daniel Kayiwa) #9

Lower versions should work fine too. Can you switch to InnoDB?


(Herbert Yiga) #10

@dkayiwa @ssmusoke @samuel34 , i changed my database to Server version: 8.0.12 MySQL Community Server - GPL and this is what i get after running show variables like "%storage%, 1 .

but still after running mvn openmrs-sdk:setup i ge this error.https://hastebin.com/uzisenaruq.sql I have read a couple of solutions from @dkayiwa and @ssmusoke which include upgrading to the latest sdk,setting a root password for root and all are still failing


(Herbert Yiga) #11

@dkayiwa

i switched to InnoDB,and i got to this error , https://hastebin.com/uzisenaruq.sql showing that still the database still cant connect


(tendo kiiza Martyn) #12

@herbert24 do you want to re-run “mvn openmrs-sdk:setup -X” so folks can get a detailed log.


(Herbert Yiga) #13

for this i changed the mysql database version to 5.6 and it worked fine.The problem was version conflict.


(Samuel Male) #14

So you got this fixed? Could explain in details starting from the issue you faced and how it was solved. It always helps others that hit upon the same issue. :slight_smile:


(Herbert Yiga) #15

i explained it above basing on the flow of the thread,thanks for the support