Understanding OpenMRS Demo.

Hello Comrades!

I have been using two kinds of links for the OpenMRS Demo. I have been seeing https://qa-refapp.openmrs.org/ and https://demo.openmrs.org/ but all these links seem to take to the same site with different url.

At moments, i feel like using the already hosted OpenMRS demo to produce the bugs or understand more of the descriptions on tickets. I do this because accessing the demo is more faster that running it locally/localhost.

  • Does the demo come packaged with all OpenMRS modules? If not, how can i add a module into the demo.
    1. Is this recommendable for me to do?
    1. Do i just upload it like the way i do it locally?

Joshua cc Any one willing to help @dkayiwa @ibacher @mozzy @herbert24 @sharif @k.joseph

  • https://qa-refapp.openmrs.org/ is the QA(Quality Assurance) sever basically for Testing . it is daily updated with the latest merged changes in the modules.

  • https://demo.openmrs.org is the Demo (Demonstration) server. it is only updated once in a while with the latest released version of Reff app. so it is the demonstration of the latest release .

2 Likes

Yes the demo has all the reff-app modules ,but you are not allowed to add any modules manually to the demo nor the qa.

For reproducing bugs , you can use the qa since it has the latest changes

1 Like

To add on @mozzy 's suggestion ,Actually he cannot do it ,inortherwords there is no privilege for adding a module manually on demo or qa-server , however if you want to test your changes locally you can setup a running server locally by using sdk or run openmrs standalone

1 Like

thanks @mozzy.

But am allowed to add stuff(patients, forms …)! Right!

IS the user data also deleted with the update? Like if u had created a patient, form, …, is that data persisted after system update? So this means i want to add a feature that i might use for months i should use my local

ya , the docker volumes are destroyed/not persisted between deployments

1 Like

I use the Reference Application for my development and testing but it takes some 12-20 minutes to load and if its running, i cant run any other task.

Sorry about this, i think it may be RAM on your machine

1 Like

Yea man, that`s the exact problem, will add more RAM.

btw the easiest way is running docker image for openmrs , its very light compared to standalone and you can do development and testing , you can try that also

Wow​:astonished::astonished::astonished:! This is great. Don’t I have to be having a high graphics card to use docker, I tried it once in 2019. When it refused, I decided to chill docker since the standalone version had worked properly.

1 Like

Which version of the reference application are you running?

1 Like

how to do you run your instances ?? docker , sdk , standalone or enterprise installation ?? by the which OS do you run ??

1 Like

i was using OpenMRS RefApp 2.9 but yesterday i downloaded OpenMRS RefApp 2.11 and its what i am going to use now.

I use Windows 10 x64 bit

If you have the bandwidth, try the reference application version 2.12.0-SNAPSHOT, which is based on platform 2.4 and hence loads faster.

1 Like

Am gonna try out this. Thanks @dkayiwa! i will give you feed back tomorrow.

https://ci.openmrs.org/build/result/artifactUrlRedirect.action?planKey=REFAPP-OMODDISTRO&buildNumber=10957&artifactName=referenceapplication-standalone-snapshot

1 Like

Thanks @dkayiwa :smiley:

Thanks @dkayiwa .

Based on your OS

I was also going to recomend running a standalone

1 Like