Unable to update patient search to add new fields

Hello, I am trying to update patient search to have more fields like “primaryContact” …I have updated “.json” file to have givenNameLocal, primaryContact and gender but every time I get an error …Even if I just update label value in following code, it gives me the same error…Any suggestions:

“customAttributes”: { “label”: “रुग्णाचे नाव”, “placeholder”: “रुग्णाचे नाव”, “fields”: [“givenNameLocal”, “middleNameLocal”, “familyNameLocal”] }

I don’t know the answer to your exact question (maybe someone else can help). But this video playlist which shows how to configure Patient Registration screens might be helpful: https://www.youtube.com/playlist?list=PLzknGpbejfSzabj6Gj5YWwAXTaYHOXLqb

@hpal, Can you paste the error message here? Are you following this Bahmni WIKI Page?

gender can’t be configured.

Is this the updated section ? Can you share screenshot of error and updated configuration.

Facing the same issue. Here is the modification that I have done to app.son (see the added Custom Attribute below; “mobileNumber” is a person attribute type that I have defined in openMRS):

“patientSearch”: { “address”: { “label”: “Rural Ward”, “placeholder”: “Enter ward”, “field”: “address2” }, “customAttributes”: { “label”: “रुग्णाचे नाव”, “placeholder”: “रुग्णाचे नाव”, “fields”: [“givenNameLocal”, “middleNameLocal”, “familyNameLocal”]

	"customAttributes": {
                "label": “Mobile Number",
                "placeholder": “Mobile Number“,
                "field": “mobileNumber"


On making the above changes and loading the Patient Search page, it’s giving me following error: SyntaxError: JSON Parse error: Unrecognized token '?'

Hi @mks,

Please replace the double quotation marks with " and try. That is causing the SyntaxError: JSON Parse error: Unrecognized token '?'

Yes @binduak might be right, you see ‘’(single quote twice) and "(double quote) or even " and “ is different.

basically it all depends on the character encoding.

Thanks! It worked!

However, now facing a different issue. Added “Mobile Number” as a search field and it indeed searches on Mobile Number (mobileNumber in openMRS) attribute, but look at the column header below encircled in red:

Another Question: How do I add more search fields? For example, Mobile Number, Caste, Gender, etc. It seems as if I could add only one customAttribute.