Unable to transition from standalone to enterprise (database import error)(solved)

I exported the database ofbthebstandalone openmrs 2.7 on MySQL workbench 6.3 according to the instructions in this wiki page: https://wiki.openmrs.org/plugins/servlet/mobile?contentId=65601935#content/view/65601935 But when I tried to import the database to MySQL where the enterprise version is installed, I got the following error: https://pastebin.com/Fv3iuYjD What am I doing wrong? Thank you

Update: Before importing the database I have to create a new database called ‘openmrs’ then start importing

@hossam your standalone database does it contain important data or just demo data? if i get you well you’re trying to export /migrate your data from standalone to OpenMRS enterprise!

If your stand alone database has succesfully why not do a more primitive dump like

with acommand similar to mysql -h [hostname] -u [uname] -p[pass] [db_to_restore] < [backupfile.sql] at your commandline. That will quickly restore everything in some instance of time

yes you do understand me well. and yes the standalone database contains important data because I already created patients on it and have obs saved on it. the cause of the error i got was because on the new MYSQL I didn’t create a database called “openmrs”…I imported right away. when I fixed that, it worked.

Thank you!

1 Like

Plus according your error log ,the log is saying "ERROR 1049 (42000): Unknown database ‘openmrs’ "

are you certain a database called openmrs exists in your MySQL database, …Try running “Show all databases” perharps you gave it a slightly different name during installation

1 Like

well great to hear it worked well

1 Like