Unable to start OpenMRS issue

Hello everyone, After i finished installing openmrs 2.3.3 and pasting the reference application 2.11 addons in the modules folder i get this page:

This is the log: Unable to start Openmrs - Pastebin.com

NB: I’m using openmrs 2.3.3, mysql 5.6.30, java 8(jre1.8.0_251), tomcat 7.0.107

Thanks

try removing the fhir module from the openmrs modules folder and re-start again

Hi @herbert24, when i removed the fhir module i was able to login with the legaci ui and i tried to restart the reference module and i got this error:

The line java.lang.OutOfMemoryError: GC overhead limit exceeded indicates that the JVM is running out of heap space. You can increase the heap space by supplying the value in the openmrs-runtime.properties file. For example to increase to 256MB add the following.

# other runtime properties...
vm_arguments=-Xmx256m -Xms256m
1 Like

Hi I am trying to install 2.3.2 war and getting following error On updating DB. image Server logs are : https://pastebin.com/2Ny4MH01 I have already tried to drop the Db and tried still getting same error. Selected No to update DB but its still updating during install. Please help.

Thank you @willa, i will have a try.

Hi @herbert24, Removing the fhir module did not resolve the problem. it just created other issues.

Just in case you find this useful: Troubleshooting Memory Errors - Documentation - OpenMRS Wiki