Unable to setup the reference module

I have followed all the steps as per the instruction given in the getting started doc but still showing this

Which errors do you get ?

when i am doing the mvn jetty run command this page is showing to install the module even though i have already installed it.

What excatly is your goal , just a platform setup or an openmrs instance with a default UI and modules ? if that’s the case then during setup then use SDK and choose distribution instead of platform during prompts.

a platform setup with the reference application module.

Which platform version have you setup ?

You can actually checkout the various reference application module versions and their platform version compatibilities at https://addons.openmrs.org/

It is not showing the version

You should check your openmrs.properties file , it should have the version.

I don’t have the app i am cloned it form GitHub i am trying to set up a development environment.

Have you tried the SDK to help you setup the platform

Thanks for the link i will try and see if it helps

I tried setting up using Openmrs sdk but when i run its giving me this:

which mysql version are you running?

mysql Ver 8.0.27 for macos11.6 on x86_64 (Homebrew)

the console is stuck here:

Which database driver did you put in the setup wizard screen?

I choose h2 database

To make your life easier, just run the setup wizard again and choose the Simple installation method.