Unable to run legacy UI module on openmrs-core

I ran the master branch of openmrs-core with mvn jetty:run. The server was successfully setup. Then I added the legacy ui module to modules folder and again ran the mvn jetty:run command but the following error occured. https://pastebin.com/RuSGteYJ

What were you trying to do, you cloned openmrs-core , and then the server successfully setup, are you using openmrs-sdk?to set up the server not getting you very well.where did you upload the legacyui module please eraborate more thanks

@sharif No I am not using the sdk I have cloned the openmrs-core and then I have pasted the .omod file in the module folder.

This problem occurs only with the master branch. I checkout to 2.3.x and everything ran perfectly.

1 Like

Am just confused about building the openmrs-core and you have an extension of .omod file. openmrs-core when its packaged ,it is bundled as a war file, forexample “webapp/target/openmrs.war” so for it it has no omod file, then you can deploy your war file in to the application server running like tomcat or jetty. hope am not mistaken can you show us the .omod file extension location in openmrs-core where you pasted the your files thanks again

@sharif Maybe I am not able to explain properly Sorry for that . I have successfully run the openmrs-core and it shows either use a UI or RESTAPI. So I want to use the UI I am following Installing the Legacy UI module and this is not working for the master branch but works for 2.3.x

@sharif have you tried to reproduce his problem and failed?

1 Like

Not yet @dkayiwa, But have got him collect now , At first the explanation was a bit not appealing fair so i couldn’t get him right, @sidvaish97 Did you restart the server on a stable internet connection

@sharif I have tried it quite a lot of times and it fails as I have told that 2.3.x works fine but not the master branch

1 Like

This link will help you OpenMRS won't start. feel free to come back to us please thanks

@sharif at this stage, you need to first try reproduce the reported problem and confirm that it does not fail for you, before you continue directing him to other links.

1 Like

Ok @dkayiwa let me reproduce the problem first

@sharif Any updates on this?

@sidvaish97 can you create a ticket for this?

@dkayiwa Sure In the core or the legacy ui module JIRA?

In the legacy ui module JIRA project.

@dkayiwa Here it is LUI-154

@sidvaish97 i have just made a commit to the legacyui module. Update, compile, and then deploy it for another round of testing.

@dkayiwa Works fine now :+1: