Unable to overridePrimary Patient Identifier

refapp
patientidentifier
identification
Tags: #<Tag:0x00007f23d3824670> #<Tag:0x00007f23d38244e0> #<Tag:0x00007f23d3824350>

(Daniel Kayiwa) #21

Does that mean you are not able to create the patient on that server? https://uat-refapp.openmrs.org/openmrs/registrationapp/registerPatient.page?appId=referenceapplication.registrationapp.registerPatient


(Nicolas Piaget) #22

Yes exactly. I still get the same error.


(Daniel Kayiwa) #23

I just created a patient on that server without any errors. Am i missing something?


(Nicolas Piaget) #24

Sorry just got back to my office.

It seems that the changes I have made are gone in the Patient Identifier admin. Are you available now to test it? Or any time later? I can apply the changes and you try as well.


(Daniel Kayiwa) #25

Yes am available.


(Nicolas Piaget) #26

OK thanks! I will do the changes now and let you know when they are done.


(Nicolas Piaget) #27

OK I have done the changes and check registration. I’m not able to register a new patient:

Validation errors found: Select a preferred identifier


(Daniel Kayiwa) #28

What are the exact changes that you made on this server?


(Nicolas Piaget) #29
  1. On https://uat-refapp.openmrs.org/openmrs/admin/patients/patientIdentifierType.form?patientIdentifierTypeId=3:

    • Identifier validator to none
  2. On https://uat-refapp.openmrs.org/openmrs/module/idgen/manageIdentifierSources.list:

    • Add a new source for OpenMRS ID of type Local Pool of Identifiers with the name: Generator for ELWA ID
  3. On https://uat-refapp.openmrs.org/openmrs/module/idgen/viewIdentifierSource.form?source=2

    • Upload a file with the following content:

      {"identifiers":["19-01-888899887","19-01-888899888","19-01-888899889","19-01-888899890","19-01-888899891","19-01-888899893","19-01-888899894","19-01-888899895"]}

  4. On https://uat-refapp.openmrs.org/openmrs/module/idgen/editAutoGenerationOption.form?autoGenerationOption=1

    • Change the Source to Auto-generate to Generator for ELWA ID

(Daniel Kayiwa) #30

Can you attach the exact file of identifiers that you used to upload?


(Nicolas Piaget) #31

Thank you very much Daniel for the follow up!

Here is the file:

ELWA_ID_pool.txt (163 Bytes)


(Nicolas Piaget) #32

Hey Daniel,

Did you have a change to look at the problem? Do you know if the problem is coming from a wrong configuration on my side or if is a code issue?

I was wondering if the problem would still arise if I allow the manual override of the primary identifier in the registration app. However the documentation is a bit short on this:

https://wiki.openmrs.org/display/docs/Registration+App+Configuration#RegistrationAppConfiguration-ManualOverrideofPrimaryPatientIdentifier

Could anyone help me with this ?

Thanks!


(Daniel Kayiwa) #33

I have noted that for those changes to take effect, you need to restart OpenMRS. Can you do so?


(Nicolas Piaget) #34

Yes, it worked. Everything is working fine now.

Thank you very much for your help. Highly appreciated!