Unable to install OpenSHR on Ubuntu Linux server

Tags: #<Tag:0x00007fddf3c4d118>

Hello ,

I have installed OpenMSR on Ubuntu Linux server. I am trying to install OpenSHR using below commands as suggested in https://wiki.openmrs.org/display/docs/Case+Based+Reporting+Module

sudo add-apt-repository ppa:webupd8team/java sudo add-apt-repository ppa:openhie/release sudo apt-get update sudo apt-get install openshr

Giving error: Unable to locate Openshr package

Thanks in advance.

@wyclif ever come across this?

@madhugandi those instructions aren’t the official ones, I wrote that for the CBR project and could be outdated, can you please refer to the SHR documentation from the OpenHIE website for the latest instructions.

Hello Wyclif,

Thanks for the response. I am able to run it on Ubuntu 14 but on 16 those packages are not available. I have set up on Ubuntu 14. I have one more query. After installing openhim and client registry, I tried setting up xds-mediator. API port with 8300, I am getting unauthorised for openhim with https from browser. Able to access with http with port 8600 mentioned in openhim-console file in nginx.

When I tried to start xds-mediator using Java -jar I am getting can’t bind address error.

Thanks in advance

The documentation says ubuntu 14, so i guess stick to it if it doesn’t work on 16.

@madhugandi are you setting up OpenHIE for case based reporting or something else? That documentation you referenced is specifically for case based reporting and if you’re setting up your OpenHIE for something else you should follow the documentation on the OpenHIE website.

Hello Wyclif,

Thanks for the response. I am trying to set case based module using the document. I have given different port numbers for openshr, openempi and openhim.

Regards,

Madhu

@madhugandi then I think you need to read that documentation for CBR carefully, the details are in there about the ubuntu version, how to set up the ports correctly and how to run the mediator.

Hello Wyclif,

Thanks for the response. I have registered Xds-mediator successfully. The patient details added in OpenEMPI not reflecting in OpenSHR and vice versa.

I have added route in OpenHim xds channel for openSHR and OpenEMPI with their port numbers.

Could you please help how to establish communication between CR and OpenSHR.

Thanks in advance.

@wyclif regarding the post I have tried to look on the website where there are instructions on how to install and configure openSHR I have not managed to get it.Can you please help.I tried using the jembi instruction on github and it seems like the openshr package is using java 8 as one of its dependencies and the license is no longer available to java 8 and on ubuntu 16.05 LTS it gets installed but the openshr package could not be installed because the repository was made for ubuntu 14.

Thanks in advance.

I’m not sure I’m understanding fully what the issue is you are facing with the java version.

I’m also confused about what exactly you are trying to install, is it just OpenSHR or the entire CBR stack? We dockerized the CBR stack here, so a demo instance of the entire CBR stack can be setup from docker-compose quickly, it all documented in that repo’s readme file.

That installation process is fairly complex, I can’t tell what exactly could be blocking you from what you just shared.