unable to install bahmni in centos 6.8

i have followed the steps documented here to install bahmni with a demo data base https://bahmni.atlassian.net/wiki/display/BAH/Install+Bahmni+on+CentOS

but when i run grep bahmni it only shows that only the rpm is installed and other components are not and even the browser dose not open them

Hi, Can you paste the output of yum list installed | grep bahmni


here it is

[root@osboxes osboxes]# yum list installed | grep bahmni bahmni-installer.noarch 0.83-142 @/bahmni-installer-0.83-142.noarch

thats the output i get it does not show other componets

Can you run the command bahmni -i local install It will install all the other components. Then run the command yum list installed | grep bahmni and paste the output here.

i did run that because i was trting to install the latest box but the i still get the same results

Can you please paste the error that you are getting when you run the install command.

Can you please check whether selinux_state disabled or not in /etc/bahmni-installer/setup.yml file ?

i set it to enforcing

Can you please set to disabled and try the installation ?

ok, let me try that

the installation is still underway but i have already got this error

Ya it is just a check for Is mysql already installed in your machine or not. It doesn’t cause any problem for the installation though.

it failed again

bahmni grep stiil returns the same output

Are you able to access this url ? https://dl.bintray.com/bahmni/rpm/rpms/

yes, i can

bahmni-openmrs-0.83-8.noarch.rpm is available here https://dl.bintray.com/bahmni/rpm/rpms/. Are you able to ping/curl to the url https://dl.bintray.com/bahmni/rpm/rpms/ from your vagrant box ?

yes that rpm i saw it ok… im bit lost now, by ping you mean execute it from the terminal?

another question, do i have to install the vagrant box first? because in the documentation i do not recall installing it, but i installed bahmni for windows prior and it was required i installed the box

Sorry you don’t need check ping/curl. Since it is unable to install the rpm, I thought it is not able to reach the url. Ya vagrant box is necessary unless you are trying to install it in CentOS.