Unable to connect to OpenMrs database

Application Name:: OpenMrs Distribution

Question: I have seen many other threads having the same problem ,but none of the solutions worked for me.

??? Unable to connect to database ?? ???User account root does not work. Could not create connection to database server. Attempted reconnect 3 times. Giving up. See the error log for more details???

This is the error i get when launching the application in the localhost. I have checked user credentials in runtimeproperties and ports seem to be working too.

Please help.

Can you paste the server side log at pastebin.com?

Hi …I get the same error…running mysql 5.6 in a docker container and installing 1.9.11. I think it is not a connectio issue, since user openmrs_user is actually created.

Try to post the server side log at pastebin.com as @dkayiwa suggested

@ganguyo try using mysql 5.7 and use pastebin.com as advised above

Also try to verify that your mysql is up and running.

1 Like

Hi…do you mean the tomcat logs?

So the team says I have to strictly use 5.6 that is the version they currently run on

Yeah sure. Tomcat logs

@ganguyo you might get challenges…

have a look at this https://wiki.openmrs.org/display/docs/Step+by+Step+Installation+for+Developers