Unable to add condition

Tags: #<Tag:0x00007f569bfa1c40>

Openmrs-2.9 , I am unable to add a new condition for the patient and getting error like 'error saving condition.

Log file error. |

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) refapp_1 | at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61) refapp_1 | at java.lang.Thread.run(Thread.java:748) refapp_1 | INFO - LoggingAdvice.invoke(115) |2020-03-12 22:44:32,023| In method ConditionService.save. Arguments: Condition=Condition[hashCode=72855ba2,uuid=4f79eb4f-148f-4c3c-b67b-ef964b50cc9b], refapp_1 | INFO - LoggingAdvice.invoke(155) |2020-03-12 22:44:32,040| Exiting method save refapp_1 | ERROR - BaseRestController.handleException(115) |2020-03-12 22:44:32,045| null refapp_1 | java.lang.NullPointerException refapp_1 | at org.openmrs.module.emrapi.conditionslist.contract.ConditionMapper.mapConcept(ConditionMapper.java:74)

Are you able to reproduce that here? https://uat-refapp.openmrs.org/openmrs/

Which coreapps and Core version are you running ??

@mozzy @dkayiwa The links, i am using. https://sourceforge.net/projects/openmrs/files/releases/OpenMRS_Reference_Application_2.9.0/

Demo app also it is not saving.

Full log after click patient and try to add condition. https://pastebin.com/KWWn0kLF

Yes, i could in UAT also.

Can you please try to list the steps your following ?

Does this link help? Unable to add new conditon

I had the same issue before and I changed the locale to ‘en’ from ‘en_GB’

John

@jesplana @dkayiwa I am getting similar error mentioned in the previous link. I added ‘en_GB’ and location. the null point error is coming when i click the patient profile and also condition drop-down is not listing default values like ‘fever’. etc.

Full Log below https://pastebin.com/KWWn0kLF

@dkayiwa Any help in this much appreciated.

Are you able to reproduce that problem here? https://uat-refapp.openmrs.org/

@dkayiwa, Can i set-up live session and show to you? I am in CST time. What is the best time to connect and show. Can you please share your email pls.

Thanks Prapa

@dkayiwa I just checked UAT screen, it looks issue was fixed. Could you please push the latest fix to the location below. https://sourceforge.net/projects/openmrs/files/releases/OpenMRS_Reference_Application_2.9.0/

You can download the modules/addons with the fix from here: https://ci.openmrs.org/browse/REFAPP-OMODDISTRO-9674/artifact

@dkayiwa Let me try this. Is there any test data in it. Can i use like sourceforge image or is there way to push fix alone to https://sourceforge.net/projects/openmrs/files/releases/OpenMRS_Reference_Application_2.9.0/

@dkayiwa @cintiadr Is there any chance add code fix to https://sourceforge.net/projects/openmrs/files/releases/OpenMRS_Reference_Application_2.9.0/ or new build for 2.9.1 something.

Any reason why you don’t just update your modules to the ones in the link that i gave you?

@dkayiwa we have completed testing 2.9.0 release and just need to update module for condition(not adding issue). May i know the fix is part of which module. It would be good, if you could tell exact file to update in our 2.9.0 release.

Try the coreapps and emrapi modules.

@dkayiwa, @jesplana I downloaded reference application and war file from https://ci.openmrs.org/browse/REFAPP-OMODDISTRO-9691, but same error. Unable to save the condition. https://pastebin.com/KWWn0kLF

Are your module versions the ones as here? https://qa-refapp.openmrs.org/