Unable to access the loaded openmrs module[SOLVED]

I cloned the git repository of openmrs-core and ran the application. I used the jar file of openmrs-module-legacyui and it is working good.

After that, I created a new module department by using mvn openmrs-sdk:create-project, built the project and uploaded the .omod file in the openmrs manage module section.

The module is shown in the admin section but on clicking the module name, it shows 404 error. The only modules that I have in the OpenMRS application are, OpenMRS module legacy UI and the newly created department module.

I didn’t do any modification in the module after I created it.

Please help me to solve this issue.

@sam1220 , Module projects created by the SDK for old openmrs versions have a few little bugs which were fixed in module projects for later openmrs versions. try creating a project running on reff app 2.9 and test it out

however that can also be easily debugged. its most likely a misconfiguration in the controller mapping. you should correct it to point to the right page

Thanks. Correction in controller mapping solved the issue.

1 Like