Unable to access the forms in lfhcforms module

lfhc
laos
Tags: #<Tag:0x00007fb858808780> #<Tag:0x00007fb858808578>

(Chukwuma Nwaugha) #1

Application Name: OpenMRS Version Number: 2.3.1

The inbuilt forms in lhfc module are not displaying, as I keep getting: Error! java.lang.IllegalArgumentException: Cannot use uiInclude tag if no UiUtils object is available when trying to access the forms from html form entry. Can anyone help with this?


(Daniel Kayiwa) #2

What is the lfhc module? Can you share the link where you got it from?


(Chukwuma Nwaugha) #3

@dkayiwa I got it here: https://github.com/mekomsolutions/openmrs-module-lfhcforms. And sorry, it’s lfhcforms module


(Darius Jazayeri) #4

@mksd, @mksrom FYI


(Dimitri R) #5

@cpnwaugha,

This module is one of several changes made to the Ref App distro 2.3 to obtain the LFHC-specific distro. Unfortunately we have not yet organised this as a distro with its own repo (as it should be done really), the distro is put together by our CI server and that is where the specific configuration is saved.

Anyway you would have to swap at least all these:

  1. openmrs-module-referenceapplication with openmrs-module-referenceapplication-lfhc.

Let us know how it goes.


Out of curiosity, could you give us some background as to why you are interested in this distro?


(Chukwuma Nwaugha) #6

Thanks a lot @mksd for you timely response. As per your curiosity, I stumbled upon the distro when I was trying to customize the register patient form. Having explored some of the functionalities presented by the distro, I do hope to tailor it to meet our needs, instead of having to build something from scratch. I will try it out and let you know the outcome.


(Chukwuma Nwaugha) #7

Sorry to bother you @mksd, but I am getting the following error: Non-resolvable import POM: Failure to find org.openmrs.distro:referenceapplication:pom:2.4-SNAPSHOT in http://mavenrepo.openmrs.org/nexus/content/repositories/public was cached in the local repository, resolution will not be reattempted until the update interval of openmrs-repo has elapsed or updates are forced @ line 47, column 25 when I try to build the module from cli.

I read a few articles online on how to fix it, and I then changed 2.4-SNAPSHOT to 2.3-SNAPSHOT, yet the problem persisted. Any Idea on how to fix this?


(Dimitri R) #8

You are not telling us which module you are having this issue with. But whether it is Core Apps or the Reference Application module, try 2.4 (instead of 2.4-SNAPSHOT).


(Chukwuma Nwaugha) #9

So sorry about that @mksd. It’s both referenceapplication-lfhc and coreapps module. Am going to quickly try what you suggested.


(Chukwuma Nwaugha) #10

Good morning @mksd, @dkayiwa, @darius, and @mksrom. I have not been able to build 2 of the 3 modules you specified, which are the coreapps and referenceapplication-lfhc modules. I have done what @mksd suggested yet I continue to get a build failure, and the error report reads: Failed to execute goal on project referenceapplication-api: Could not resolve dependencies for project org.openmrs.module:referenceapplication-api:jar:2.3.0.1: Failed to collect dependencies at org.openmrs.module:referencemetadata-api:jar:2.4: Failed to read artifact descriptor for org.openmrs.module:referencemetadata-api:jar:2.4: Failure to find org.openmrs.distro:referenceapplication:pom:2.4-SNAPSHOT in http://mavenrepo.openmrs.org/nexus/content/repositories/thirdparty was cached in the local repository


(Dimitri R) #11

This is the never ending problem of released modules still depending on a SNAPSHOT version of the Ref App distro… It turns out that Reference Metadata version 2.4 depends on distro 2.4-SNAPSHOT.

This is a tricky situation and there is no easy workaround here. You may try to depend on 2.5-SNAPSHOT then instead of 2.4 but we haven’t tested this yet and I can’t guarantee that this will work.


Request To confirm Modules For Reference Application 2.5
(Shelter Editor) #12

Hi, I am facing the same error after uploading “lfhcforms-0.5-SNAPSHOT.omod” Any suggestion or idea, how to overcome this error Error! java.lang.IllegalArgumentException: Cannot use uiInclude tag if no UiUtils object is available


(Dimitri R) #13

LFHC Forms 1.0.0-SNAPSHOT is in the works on the feature branch LFHC-192. Could you try to build the project out of that branch and give it a shot?

Cc @zouchine


(Shelter Editor) #14

I just built from LFHC-192, and got the same error Error! java.lang.IllegalArgumentException: Cannot use uiInclude tag if no UiUtils object is available

Am I missing some steps? Do I need to do some other setup before click these forms I go to Edit HTML Form and just clicked Wound Details form At the bottom in the preview section got this error. Error! java.lang.IllegalArgumentException: Cannot use uiInclude tag if no UiUtils object is available


(Dimitri R) #15

You have installed that module on top of the Ref App distro right? And what exact version of the Ref App then?


(Shelter Editor) #16

I am using reference application-standalone-2.8.0


(Dimitri R) #17

You mean that in the legacy UI administration page you have clicked on Manage HTML Forms?

It would be helpful if you could share as much as possible about the steps to reproduce this.


(Shelter Editor) #18

Yes I just clicked the Manage HTML Forms