unable to access 'https://github.com/dkayiwa/openmrs-module-xreports.git/'

What could be the problem @dkayiwa

@dkayiwa could i change XREP-6 to the full url?? i tried this but its not working

yes go ahead.

@dkayiwa this is what i get

@herbert24 @reagan @sharif

Hope this may be of help invalid refspec. if you are still getting the same error, another option is to get a fresh openmrs-module-xreports.

I tried to google but didnt get solution to this… any help will be greatly appreciated @sharif @dkayiwa @reagan

I suppose the problem can be solved by changing the authentication method from HTTPS to SSH. Kindly create a SSH key in your github account ( https://github.com/settings/keys) if you don’t have one.

Hello @ndacyayisenga why is it that in my case i can be able to run it successfully on my machine,

do you have this repo forked on your repository, can you try a fresh clone install and try again with your new commits

@sharif when I look at the screenshot that @ndacyayisenga shared, it seems he is running into the error while pushing the commit basing on

git push --set -upstream

command reflected on the screenshot of which can only be solved by having correct authentication to the github account.

Thanks @jwnasambu, i have been able to access this repository through this example xreportTest here, so i would again advise to let him clone a fresh and try again