UI test uilding failure

Hello, It seems that something has changed in the developement process. In the past after a commit of UI test, they were built to run against to the online server https://qa-refapp.openmrs.org/openmrs. In the past, they failed because I didn’t have a sauce lab account. Now they are failing because the test are executed against localhost, I get this error message: org.openqa.selenium.firefox.NotConnectedException: Unable to connect to host localhost on port 7055. (the entire log) Is there any server active on that port? Keep in mind when I run locally the tests, they are executed against https://qa-refapp.openmrs.org/openmrs and not on my local PC ( I have no openmrs server installed). Additionally, to my knowledge I can change the address of the server only in the pom.xml . It is strange to me that the tests are executed against localhost:7055 after the commit. It sounds like they are executed on the build server which should have an Openmrs locally installed. Are you aware of any change in the build process? Thank you

Which command are you using to run these tests locally?

Dear @dkayiwa, Tipically I run the test inside Eclipse with the run command, anyway in Maven I use a command such as mvn -e -DfailIfNoTests=false -Dtest=AddDeleteLocationTest integration-test

and it works with no problem. Hereafter a fragment of the log after the execution.

Running org.openmrs.reference.AddDeleteLocationTest Running locally… log4j:WARN No appenders could be found for logger (org.apache.http.client.protocol.RequestAddCookies). log4j:WARN Please initialize the log4j system properly. Running locally… Tests run: 2, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 78.301 sec

Results :

Tests run: 2, Failures: 0, Errors: 0, Skipped: 0

At the moment I’m stuck, I’ve also fixed another test and created a new one. Hopefully, we get ridden of this problem, otherwise my job is wasted :frowning:

The tests you have run do not show any errors or failures. Could you clarify more on where you are stuck? For cases where you are getting failures or errors, can you paste the full build log at pastebin.com? Do not forget to have that log start from the very command you are running.

Maybe I have to clarify myself. On my local PC no error, but on travis I get errors (click on raw log). About the command, I just click on “build” or “restart job” in travis that should execute mvn. Thank you for your support.

Is your travis running the latest code as that run by our CI server? Are your travis configurations the same as those used by our CI server?

My analysis:

mvn verify -Pci -Dwebapp.url=http://localhost:8080/openmrs -Dsaucelabs.hub.url=localhost:4445 -DbuildNumber=$TRAVIS_BUILD_NUMBER -Dbranch=$TRAVIS_BRANCH -DsaucelabsTunnel=$TRAVIS_JOB_NUMBER -Dmaven.junit.usefile=false

Thank you in advance.