UI Framework Error with DIT

Platform Version: : Data Import Module OpenMRS Version: 1.11.3

Question: I am currently working on the UI for the Data Import Tool using the UI framework module. I’m still at the beginner stages of it’s development. I’ve setup the dataimporttool.gsp with some sample text, but I get this error when I run from Admin Panel

@darius or anyone, Could you help me out here? Here is the dataimporttool gsp

@ch3ck the error says that there is no “view provider” named “dataimporttool”.

Have you done the first two things mentioned in this wiki page?

  • Depending on the UI Framework module

  • Beans in webModuleApplicationContext.xml

@darius, I’ve done them and even re checked, still no changes. But I’m getting this error when I’m trying to set the module to development mode.

WARN - UiFrameworkUtil.checkAndSetDevelopmentModeForProvider(551) |2015-07-23 23:06:54,222| Failed to set development mode for ConventionBasedClasspathPageControllerProvider in dataimporttool because it does not exist or is not a directory

In the screenshot in your original message you have typed the URL wrong. You typed dataimportool (with one t) when it should have two.

As far as why development mode doesn’t work, can you please make sure that the VM argument’s value is typed exactly right, and points to the root directory of your module’s code? (If you have a space in that path, you need to make sure to escape it correctly.)

@darius, Thanks very much, How did i miss that?

What the meaning of this error:

groovy.lang.MissingPropertyException: No such property: migrationSettings for class: SimpleTemplateScript11. 

I don’t seem to find much info on this on StackOverflow.

It means that somewhere in your code you do something like ${ migrationSettings } or $migrationSettings, but that there is no property called migrationSettings coming from the page’s (or fragment’s) controller.