TypeError: t is null

Hello Friends,
Am using a QA server to run my tests. The funny part is all my tests which were passing prior are now failing. The logs on line 101 has this enmrs.org/openmrs/ms/uiframework/resource/uicommons/scripts/jquery-ui-1.9.2.custom.min.js?cache=1643813999744, line 2: TypeError: t is null that I suspect is as a result of a typo

Could anyone help me understand the real cause of TypeError: t is null and how I can go about it? am using a firefox browser.

1. at org.openmrs.contrib.qaframework.automation.OpenConceptLabSteps.systemLoadsOpenConceptLabSuccessPage(OpenConceptLabSteps.java:94)

2. at ✽.the system loads Open Concept Lab Success page(file:///Users/juliet/Desktop/openmrs-contrib-qaframework/qaframework-bdd-tests/src/test/resources/features/refapp-2.x/16-openConceptLab/openConceptLab.feature:18)

Actually the logs specify where it could be failing and its on line 94 in the steps definition file. so the system is not able to load the Open Concept Lab Success page and this could be caused by the fact that the save changes button is not clicked. This is an issue on the qa-server. Because having tried out the demo-server, the button is clickable when the subscriptionUrl and tokenUrl are inserted. The local server that i have which is refapp 2.12 and that button is clickable aswell.

cc: @sharif @kdaud could you be seeing the samething?

in the meantime @jwnasambu try to spin from https://demo.openmrs.org/openmrs/ and see the behavior there

I have just fixed it here: TRUNK-6051 adding CsrfGuard script tag · openmrs/openmrs-module-openconceptlab@fa9591e · GitHub

So clear the cache for that page and try again.


Thanks so so much! the TypeError has disappeared.

1 Like

@dkayiwa am happy to report the refApp QA server is now steady. Thanks for your efforts.

@dkayiwa thanks for the support