Trouble while installing OpenMRS. Infinite refreshing context

Tags: #<Tag:0x00007f0f19c23128> #<Tag:0x00007f0f19c23060> #<Tag:0x00007f0f19c22f70> #<Tag:0x00007f0f19c22e80>

Hi. I’m trying to start OpenMRS on Tomcat with deployed Open Concept Lab, but I cant pass initial setup. I got 100% updating the database and whole installing process stuck on “Refreshing Context” in console. There is below my maven output: http://pastebin.com/ckZFwQ63

Also maybe my server properties would be helpful:

openmrs-distro.properties:

#Wed Nov 09 14:00:21 CET 2016
omod.htmlformentry19ext=1.6.1
omod.openconceptlab=1.2-SNAPSHOT
omod.metadatadeploy=1.5
omod.reportingrest=1.6
omod.owa=1.6.3
omod.serialization.xstream.type=omod
omod.serialization.xstream=0.2.10
omod.registrationapp=1.5
omod.event.groupId=org.openmrs
omod.event=2.4
omod.atlas.type=omod
omod.uilibrary=2.0.4
omod.htmlwidgets=1.7.0
omod.dataexchange=1.3.1
name=Reference Application
omod.appui=1.5.1
omod.allergyui=1.5
db.sql=classpath\://openmrs-distro-2.4.sql
omod.providermanagement=2.4
omod.appointmentschedulingui=1.3
omod.formentryapp=1.2
omod.idgen=4.3
omod.allergyapi=1.4
omod.metadatamapping=1.0.2
omod.chartsearch=1.4.1
omod.htmlformentryui=1.5
db.h2.supported=false
omod.referencedemodata=1.4.2
omod.emrapi=1.14
omod.referenceapplication=2.4
omod.htmlformentry=2.6
omod.appframework=2.8
omod.referencemetadata=2.4
omod.coreapps=1.10
omod.reporting=0.10.0
omod.adminui=1.1
omod.registrationcore=1.4
omod.appointmentscheduling=1.5
war.openmrs=1.11.6
omod.atlas=2.2
omod.calculation=1.1
omod.webservices.rest=2.14
version=2.4
omod.uicommons=1.7
omod.uiframework=3.6
omod.metadatasharing=1.2

openmrs-runtime.properties:

#Auto generated by OpenMRS initialization wizard
#Wed Nov 09 14:00:46 CET 2016
encryption.vector=Ly/WFPg5EhEITs482x7wXw\=\=
connection.url=jdbc\:mysql\://localhost\:3306/refapp?autoReconnect\=true&sessionVariables\=storage_engine%3DInnoDB&useUnicode\=true&characterEncoding\=UTF-8
module.allow_web_admin=true
connection.username=root
auto_update_database=false
encryption.key=eOrVQdp9JX967gwnqcJ38g\=\=
connection.driver_class=com.mysql.jdbc.Driver
connection.password=root

and openmrs-server.properties

#Wed Nov 09 14:00:21 CET 2016
omod.htmlformentry19ext=1.6.1
admin_user_password=Admin123
omod.openconceptlab=1.2-SNAPSHOT
omod.metadatadeploy=1.5
omod.reportingrest=1.6
omod.owa=1.6.3
install_method=auto
omod.serialization.xstream.type=omod
omod.serialization.xstream=0.2.10
omod.registrationapp=1.5
has_current_openmrs_database=true
omod.event.groupId=org.openmrs
omod.event=2.4
omod.atlas.type=omod
omod.uilibrary=2.0.4
omod.htmlwidgets=1.7.0
omod.dataexchange=1.3.1
database_name=refapp
add_demo_data=false
name=Reference Application
omod.appui=1.5.1
omod.allergyui=1.5
omod.providermanagement=2.4
omod.appointmentschedulingui=1.3
omod.formentryapp=1.2
omod.idgen=4.3
omod.allergyapi=1.4
create_database_user=false
omod.metadatamapping=1.0.2
omod.chartsearch=1.4.1
omod.htmlformentryui=1.5
create_tables=false
omod.referencedemodata=1.4.2
omod.emrapi=1.14
connection.password=root
omod.referenceapplication=2.4
server.id=refapp
connection.username=root
omod.htmlformentry=2.6
omod.appframework=2.8
omod.referencemetadata=2.4
omod.coreapps=1.10
omod.reporting=0.10.0
omod.adminui=1.1
omod.registrationcore=1.4
omod.appointmentscheduling=1.5
auto_update_database=false
war.openmrs=1.11.6
connection.driver_class=com.mysql.jdbc.Driver
omod.webservices.rest=2.14
omod.calculation=1.1
omod.atlas=2.2
version=2.4
omod.uicommons=1.7
module_web_admin=true
omod.uiframework=3.6
connection.url=jdbc\:mysql\://localhost\:3306/refapp?autoReconnect\=true&sessionVariables\=storage_engine%3DInnoDB&useUnicode\=true&characterEncoding\=UTF-8
omod.metadatasharing=1.2

Thanks

How about you first install OpenMRS without any modules? Then add all the modules without OCL module to confirm whether it’s not the culprit

It looks like you’re using java 8 to build and deploy. If Wyclif’s suggestion doesn’t work, I would switch to java 7 and make sure to set the CATALINA_OPTS to 1GB or more if you have enough RAM on the machine.

Here’s the command I use to set CATALINA_OPTS in the setenv.sh file

echo 'CATALINA_OPTS="-Xms512m -Xmx1512m"' | sudo tee --append /usr/share/tomcat7/bin/setenv.sh

@lkukielka, is the issue resolved? Please report back, if any of the above suggestions helped.

I can run OpenMRS only without ocl, so I think it confirms that ocl is the problem

Unfortunately it did not help

Try setting MAVEN_OPTS instead of CATALINA_OPTS since you are using SDK i.e.

export MAVEN_OPTS="-Xms512m -Xmx1512m"

I did not help. I updated maven to the current version, tried to run with sudo and this both also did not work.

The issue was the OCL module required webeservices.rest 2.17-SNAPSHOT and didn’t specify it in config.xml.