Trouble setting up my openMRS

Installing the server? basing on the pastebin error log, where you are asked the username click enter. The password type the password for your mysql. The words will not appear on the screen then press enter.

I have run the installation and I chose the option of full installation, followed all the option until the point where I was asked for the username and password. when I tried to input those details, the check button below was inactive. should I select the option of customizing during the installation process

Kindly what are you installing?

mysql-installer-community- this is what i am installing

What happened to the previous version? the issue wasn’t the mysql version. It was about your password. Did you delete the previous version?

for all the mysql installations, i didn’t get the option of creating a username and password. That is where my challenge is. could i be using a wrong setup file

what do you see when you run mysql -u root -p in your command prompt?

@spkabugo1 run the above command on your command line.

i had decide to do to a fresh installation so that i get all thing right. Currently am at the step of selecting setup type where i have five options: developer(default),server only,client only,full and custom. which option should i go with

I think verifying that your mysql database is up and running would have been a better idea before restarting that process. and setting up the required passwords


do i have to be with Microsoft visual studio installed prior this or not . i am being notified that some products have failing requirements key of those am required to install visual studio C++ should i ignore this

You can ignore it.

the only products to be installed are; MySQL Notifier MySQL for Excel connector/j connector/NET MySQL Documentation sample and Example.

Is that ok? Not seeing Shell, server anywhere hope it will be of help

1 Like

Install mysql 5.6 version and ensure you set the password to the root. mark the password for you will need it while while installing the server.

@spkabugo1 can you share a screenshot for the installation step which lets you choose the destination/installation folder? You can use this to share the screenshot:

@dkayiwa I have tried several times to paste the print screen as directed, but I am getting an error" Image data was not found on the clipboard.E007". I have followed the steps to the dot. what am I not doing right

OK. Can you just type here the full destination path and folder that you see on that step? managed to get the screen shot