The requested information does not exist

Hi. I am getting this on screen error “The requested information does not exist” when i log in to Bahmni. I running Bahmni via vagrant. This error came about after creating a symlink for my bahmni_config files. The console output when i inspect the page is “Failed to load resource: the server responded with a status of 404 (Not Found)” I have attached the /openmrs/ws/rest/v1/auditlog screenshot

@ekirapa, can you look in the Manage Modules page of the OpenMRS UI and see if the “auditlog” module is installed and running?

If you do not want audit logs, you can just turn it off. see config options here

@ekirapa do let us know if the module was absent.

Gentlemen @darius @angshuonline sorry for the late reply. The audit log module isn’t on the list on the modules page as well as my output for /etc/openmrs/modules

I wonder how this came about: is this a relatively fresh install of Bahmni, or did you install an earlier version then do an upgrade?

I assume the fix is to add the audit log module in that folder and restart OpenMRS.

-Darius (by phone)

Its a fresh install. I am running it via vagrant. The error started after i linked my EMR UI folder to vagrant as guided in this article

UI folder linking shouldn’t effect the modules directory. Whats the version of Bahmni you have? One possibility is that the Vagrant file is not uptodate (i.e not 0.89) @shruthipitta: any clue how this would come about?

I am running v0.89

Hi @ekirapa

It can happen if your client side code is latest and server is older than 0.89. Can you please run yum list installed|grep bahmni? Quick fix as Darius suggested would be to deploy audit log omod in the modules folder.

@darius, @angshuonline Where to download audit-log omod from as I am also getting the same problem and audit log is missing from /opt/openmrs/modules/ (assuming that’s where it should be)

Host OS: Windows VBox: Bahmni version 0.89 atomfeed-console.noarch 1.0-18 @bahmni bahmni-emr.noarch 0.89-316 @bahmni bahmni-erp.noarch 0.89-43 @bahmni bahmni-erp-connect.noarch 0.89-43 @bahmni bahmni-implementer-interface.noarch 0.89-93 @bahmni bahmni-installer.noarch 0.89-167 @bintray–bahmni-rpm bahmni-lab.noarch 0.89-64 @bahmni bahmni-lab-connect.noarch 0.89-316 @bahmni bahmni-openmrs.noarch 0.89-83 @bahmni bahmni-reports.noarch 0.89-59 @bahmni bahmni-web.noarch 0.89-316 @bahmni epel-release.noarch 6-8 @bintray–bahmni-rpm python-gdata.noarch 2.0.11-1.el6 @bahmni

And it’s true that linking UI (bahmniapps) to my own compiled bahmniapps gives that auditlog related error. If you need I can send screen shots. But for now, I need that audit log omod

Hi @nawazshaikh,

Are you linking latest version of bahmni apps (master) to /var/www/bahmniapps? In 0.89 audit log was part of bahmni core omod but in 0.90 we have moved it out as separate omod. Hence there is a change in the API URL. In 0.89 there is no separate omod for audit log. If you want to link code for Bahmni apps, please check out to 0.89 version of bahmni apps and then link. Let us know if you are still facing the issue.

@shruthipitta We have used bahmni-installer-0.89-208.noarch.rpm. Our Audit log was working but it stopped on Oct 22nd.

After search we added a separate (newer) auditlog omod (First mistake!) and did setting in openmrs->Admin->Advanced Settings including bahmni.enableAuditLog=true

Still it didn’t work. So when we set auditlog.started = true (Second mistake!) image

and restarted openmrs it couldn’t restart at all as it fails on loading auditlog omod.

  1. Is there anyway to revert auditlog.started = true from any table?
  2. After openmrs is up, how do we restart auditlog.

@shruthipitta Even with the fresh VBox installation, audit log is not working - image

One patient created

No audit log

Done some more patient search, edit, save, consultation and suddenly the log appeared

but again after some activity it is not updating.

Does it update on every action?

As part of release 0.89 we are tracking only user navigations to different pages in the clinical app.

i am also getting same Error The Request Information does not Exits

Hello GovindSharma,

Did you manage to resolve this issue. Am also suffocating here with the same Kindly help me with the solution incase you solved it. Thanks.

@mfugale This problem is different from what you are experiencing.