The registration page is blank.

Registration/index.html doesn’t bring UI of registration. what is the problem?

Kindly on which server and openmrs version is that happening on?

bahmni version 0.93 it is on my pc … localhost.

Hi @samrizee

Can you tell what is it throwing in the console and in networks logs?

I think the problem is caused because of the extension.json file

  1. Please mention steps you performed to install Bahmni v0.93 on Windows. Is this running in Virtual Box/Vagrant?
  2. Can you check if openMRS is running fine (https://localhost/openmrs)? Can you login and see various OpenMRS Screens (superman/Admin123)?
  3. Did you make any changes to Bahmni after installation?

Answers to these questions will help debug the issue. Possible also that your installation didn’t complete properly, or VM isn’t able to load up due to insufficient RAM for multiple services (in which case some services need to be stopped, like Odoo/ELIS, so you can bring up only OpenMRS/Bahmni if RAM appears insufficient).

  1. I have successfully installed bahmni on centos 7. Registration was working fine until I touched the extension.json file of the default-config folder. 2.yes openmrs is running fine 3.yes I did (the coding ). the only module not opening is Registration module . i tried changing the registration folder with the default one but it is not working.

If you can provide some information on the changes you made, maybe that can help debug the issue. The default ones can be seen here

  1. default-config: GitHub - Bahmni/default-config: Default configuration setup for bahmni.
  2. UI code: GitHub - Bahmni/openmrs-module-bahmniapps: Angular.JS based UI application that is used by Clinicians and Patient care providers.

I tried to change the default folder and UI code of registration module with the one you sent. but this is also not working.

Don’t change the UI folder. Reset that to whatever was there earlier (if you have backup). Just change the registration folder from default-config. If that doesn’t work. You can retry installing Bahmni again… it will likely only “touch” / update those files which you modified since last install.

Did you use default-config and openmrs-module-bahmniapps repository release-0.93 branch ? So make sure that you are not in master branch and if you are already in master branch checkout to release-0.93 branch and try it.