Testing the reset password feature for Android Client

Tags: #<Tag:0x00007fa3efad8de8>

Hello everyone. I am recently working on implementing the reset password functionality for android client. I have set up all the changes required in the android client. But i need to test it. I am facing problems in it.

It was first pointing this error

Then after downloading the legacy UI it is pointing to this error

I have to carry out the things present here (https://wiki.openmrs.org/pages/viewpage.action?pageId=216367317)

Things i did - 1- Cloned the openMRS repo 2- successfully runned mvn clean package and jetty run on it 3- had a successful running server which asked for the password (I provided it too)

Can please someone help me out. I want to test this feature and i am stuck in this process. I would appreciate any suggestions any help please.

@dkayiwa @sharif @f4ww4z @ibacher

Can you just restart your OpenMRS instance?

sure @dkayiwa sir i will do it

First of all sorry @dkayiwa sir for such a late response. I had some issues with my laptop.

Secondly i tried what you said sir but it did not work and gave me the same error :sweat_smile:

Can you run it again and share the server side log?

@dkayiwa sir i tried the process i was doing 3-4 times more and the last time i tried the server ran and i am able to do the changes to the from as given in this link (finally :sweat_smile:) .
( https://wiki.openmrs.org/pages/viewpage.action?pageId=216367317 )

But can you guide me how to make changes in the database as given in the link . Like still there is no UI present for it. And if i have to use mySQL so on which table and where can i find it ??

Are you using MySQL Query Browser to access your database? Or something else?

@dkayiwa sir i am using mysql command line using terminal.

Just execute the sql statements on the wiki page that you referenced.

ok sir i will just do and let you know

@dkayiwa sir i entered my email id in it. Hope i did it right.

I guess now i just have to change the demo openMRS url from this localhost link in android client to test my feature. Please correct me if i am wrong in any way.

Yes that’s correct. What’s the progress of this @vibhorchinda17?

@f4ww4z sir i tried doing testing. For which i changed the base url to my PC’s IP address and changed but i am getting this error.

I also tried switching off my firewall but no use.

Any suggestions/advice would be great. :sweat_smile:

@vibhorchinda17 Are you sure :9999 is the correct port? Also try just using http instead of https.

Yes @f4ww4z sir 9999 was the correct port. I will use http instead of https and tell you what happened.

@f4ww4z sir Same result even after using http.

Sorry for late response sir, my university exams are going on. :sweat_smile: