standalone openmrs not opening in browser after clicking the jar file

Hi, I have a problem opening the OpenMRS from the standalone file. I open the zip file then click the jar file then nothing opens in the browser. I tried double clicking the, but it opens in the text editor instead of the browser. I am on Ubuntu. any help plz :slight_smile: ?

@monasaleh, do you have Java JDK installed on your system?

I installed it now. then I tried to open the jar file again, it did not uncompress, but did not open in the browser either.

It will be helpful in trouble shooting knowing the version of JDK you installed and also whether you unzipped the standalone zipped file correctly without making any changes to the unzipped file directory.

I installed java version 1.8.0_191(build 170114).

I am opening the jar file from inside the zipped folder without unzipping, then I upzipped it outside of (computer) folder then tried to open it again but it is not opening still.

Kindly first unzip the zipped file then from the unzipped folder without making any changes launch the jar file. An just to confirm java has installed successfully, you may try out this command java -version on the terminal to see if version displayed rhymes with what you just stated.

the terminal gives me this result: ~$ java -version java version “1.8.0_191” Java™ SE Runtime Environment (build 1.8.0_191-b12) Java HotSpot™ 64-Bit Server VM (build 25.191-b12, mixed mode)

what is the path to which I have to uncompress the zip file? is it in the (computer) path?

You can uncompressed the file to any preferred location on your computer. WinRAR works for me just fine for this, you may try it out.

OK, I uncompressed it, then clicked the (openmrs-standalone.jar), then it did not open. is this flow correct?

Dear @ruhanga, I have just watched this video

and it helped a lot. I thank you so much for your effort :slight_smile:
1 Like