Standalone OpenMRS: Issue running “openmrs-standalone.jar” file

Tags: #<Tag:0x00007f0f172ef770> #<Tag:0x00007f0f172ef680>

Standalone platform 2.10

I installed the Standalone version of OpenMRS but my computer cannot run the “openmrs-standalone.jar” file. Here is the paste log bin to the error message I received: https://pastebin.com/Ui62Gff0

Here’s the current java version and the results from when I try to run the application in the terminal: https://pastebin.com/4rqRRVVY

Does anyone know why these errors occur and what might fix them?

So far I’ve tried making sure my java version and path environment variables are correct. I’ve also tried restarting my computer and restarting the terminal.

Please let me know if you have any questions.

Sebastian

which operating system are you running?

1 Like

I’m operating Mac OS Catalina. Thanks for asking

1 Like

cc @dkayiwa @samuel34 @slubwama

1 Like

@sarceo does it help if you change your terminal to use zsh? https://support.apple.com/en-us/HT208050

Thank you for your question and the link. Yesterday I followed the instructions to that link you sent me but it didn’t work and those errors are still there.

Ok. Can you now turn to this? https://wiki.openmrs.org/display/docs/OpenMRS+SDK

yeah definitely.