Some difficulty with setting up Standalone package

Tags: #<Tag:0x00007fdb78fa4d98>

OpenMRS Stand Alone Reference Application Reference Application 2.10.0

Question: So I am very new to this application, and am trying to set this up for a mobile clinic I am a part of. I am trying to set up the standalone reference app, but it won’t work…I get the following error message when I run the Java file…

Exception in thread “driver_launched_mysqld_2” Cannot run program “/Users/kunalkapoor/Desktop/EMR/openmrs-standalone-2.3.1/database/bin/mysqld”: error=86, Bad CPU type in executable at at$Block.exec( at$Default.exec( at$ at java.base/ Caused by: Cannot run program “/Users/kunalkapoor/Desktop/EMR/openmrs-standalone-2.3.1/database/bin/mysqld”: error=86, Bad CPU type in executable at java.base/java.lang.ProcessBuilder.start( at java.base/java.lang.ProcessBuilder.start( at java.base/java.lang.Runtime.exec( at$Default$1.inner( at$Block.exec( … 3 more Caused by: error=86, Bad CPU type in executable at java.base/java.lang.ProcessImpl.forkAndExec(Native Method) at java.base/java.lang.ProcessImpl.( at java.base/java.lang.ProcessImpl.start( at java.base/java.lang.ProcessBuilder.start( … 7 more

Would anyone have any insight on how to get around this? I don’t have much technical experience, but am willing to learn!

Someone had the same problem with the stand alone ,try out what he did on this link :

or check the version of mysql you are using (32 or 64 bit) if it suites your processor and then change accordingly .

@kkapoor1 which operating system are you running?

I am using MacOS…i have also tried on the Windows partition that I have, but I couldn’t access the browser option.

@kkapoor1 I’m assuming you’re on Catalina?

Yep, Catalina 10.15.6

Unfortunately, it seems like we can’t support the standalone on Mac OS Catalina. The problem is that to support a zero-configuration database setup, we’ve been using MySQL’s MXJ product, which bundles the MySQL executable in a manner that can be launch from a Java application. Unfortunately, that product was discontinued in 2012, though it’s still distributed. Being from 2012, it was last released with only support for 32-bit processors on Mac OS. Since Catalina no longer supports 32-bit executables, it won’t work on Catalina.

That’s not to say that we cannot get OpenMRS to run in your environment, just that we probably cannot get the current version of the standalone to run there.

Probably the easiest way forward would be to install Docker Desktop for Mac and use this docker-compose file to setup an environment (just save a copy of that file locally and run docker-compose up).

Alternatively, you can follow our normal installation instructions.

Please do continue to reach out on this thread if you run into challenges with either of these options.