Some admin links not working in O3 Demo

I am running openmrs-distro-referenceapplication from GitHub. I have tried both Docker & SDK approach.

Some links in the Legacy Admin don’t work, resulting in HTTP Status 404 – Not Found. I also tried it in the O3 demo, but there is the same problem.

These are the links not working (in red): image

For now, I need to access Manage Apps so that I can configure a patient registration form following this guide:

Step 1. Navigate to System Administration–>Manage Apps

So I am stuck here on the first step.

  • Why are these links not working?
  • Is there another way to fully configure the registration app besides the limited “@openmrs/esm-patient-registration-app” configuration via Implemeter Tools?
1 Like

The steps your following are for the 2.x registration app, which doesn’t exist in O3. You can configure the @openmrs/esm-patient-registration-app using JSON as described here.

2 Likes

Thank you. It would be nice to have the non-functional links removed.