[SOLVED] OpenERP could not restart. Failed while attempting.

Tags: #<Tag:0x00007f0f1c21ed00>

[root@afnai2 ~]# service openerp status openerp-server is stopped [root@afnai2 ~]# service openerp start OpenERP Server Daemon already started. [root@afnai2 ~]# service openerp restart Stopping OpenERP Server Daemon (openerp-server): [FAILED] OpenERP Server Daemon already started.

While i checked the service status it says stopped at the mean time when i start the service displays “OpenERP Server Daemon already started” and upon the restart failed message is displayed.

Looks like the issue the openerp pid file exist on the system. Try deleting /var/run/openerp/openerp.pid and start the service.

i deleted the the file restarted again still not working

Hello @sanjayap,

Can you please try the following:

  1. Stop openerp service: service openerp stop
  2. Check for an process with openerp in it, and kill it.
    ps -ef | grep openerp kill -9 <processid>
  3. Delete the file (if it exists): /var/run/openerp/openerp.pid
  4. Start openerp service: service openerp start

Hello @sanjayap. Was your problem resolved?

Hi @gsluthra problem is solved that was due to unwanted package of python and now solved

Thanks for the update @sanjayap. Can you please mention which unwanted package / or what steps you took to solve this. The detailed steps could help someone in future, who stumbles upon the same problem.

hi @gsluthra I took support from Sandeep .

The fix was to delete the werkzeug 10.x version from python libraries. (/usr/lib/python2.6/site-packages/Werkzeug-0.10.x-py2.6.egg) OpenERP 7 need werkzeug 0.8.x version. (/usr/lib/python2.6/site-packages/Werkzeug-0.8.3-py2.6.egg)

Thanks @sandeepe. So you basically removed the newer (0.10.x) package, and then OpenERP switched to using the older one (0.8.x).

Seems like http://werkzeug.pocoo.org/ is a library for WYSIWIG editing.

I wonder why the 0.10.x library got installed on @sanjayap machine? Did some other software install it? Or was his CentOS version different, and installed some extra python libraries.

@gsluthra centos version is 6.6 with the minimal installation.

I am facing a similar problem, my Openerp is not logging in. I tried the above methods(including the wekzeug 0.8.x egg)–(I have Werkzeug 0.8.3 so i did not change it) but its still not working. This is the error on the html page. OpenERP Server Error

    Client Traceback (most recent call last):

File “/usr/lib/python2.6/site-packages/openerp-7.0_20130301_002301-py2.6.egg/openerp/addons/web/http.py”, line 195, in dispatch response[“result”] = method(self, **self.params) File “/usr/lib/python2.6/site-packages/openerp-7.0_20130301_002301-py2.6.egg/openerp/addons/web/controllers/main.py”, line 818, in authenticate req.session.authenticate(db, login, password, env) File “/usr/lib/python2.6/site-packages/openerp-7.0_20130301_002301-py2.6.egg/openerp/addons/web/session.py”, line 116, in authenticate uid = self.proxy(‘common’).authenticate(db, login, password, env) File “/usr/lib/python2.6/site-packages/openerp-7.0_20130301_002301-py2.6.egg/openerp/addons/web/session.py”, line 31, in proxy_method result = self.session.send(self.service_name, method, *args) … … File “/usr/lib/python2.6/site-packages/openerp-7.0_20130301_002301-py2.6.egg/openerp/addons/bahmni_logger/SMTPLogger.py”, line 2, in import nonblockingloghandler ImportError: No module named nonblockingloghandler

I tried installing the nonblockingloghandler 1.1* .egg and 0.4* egg (using easy_install) from the python website and its still giving me the same error. Does anyone have any idea what steps to take in order to resolve the issue?

@deepakrv: Can you please share more details of the steps you took?

Which version of Centos? How did you install OpenERP? Which version of Bahmni? (V0.80?)

I have also installed python 2.7 to test it on that, but since the default is /usr/lib/python2.6, it does not access python 2.7 Can someone tell me where to change the path variable in order to run OpenERP with python 2.7.?

CentOS 6.7 ( minimal and then installed the desktop ) with yum groupinstall “Desktop” “Desktop Platform” “X Window System” OpenERP - 0.80-59 Bahmni V: 0.80 I installed Bahmni through the normal procedure given on the website ( Install Bahmni using centOS) EXPORT VERSION=0.80

Can you try to remove “/usr/lib/python2.6/site-packages/openerp-7.0_20130301_002301-py2.6.egg/openerp/addons/bahmni_logger” folder and restart the server again.

@vinkesh Thank you, I removed bahmni_logger folder from the above directory and it worked! Now OpenERP is running successfully and I am able to install the Apps from the Apps page. I will have to sync it with Bahmni now (if not already synced) but anyway thanks a lot.

Was the Bahmni_logger folder vital towards connecting with Bahmni ?

bahmni_logger is not vital for integration or functionality.

Hi all, I’m facing the same problem. My openerp server is not starting. Tried above methods (my werkzeug is python-werkzeug-0.8.3-3.el6.noarch). But when i try to start the openerp server i get the error below:

Starting OpenERP Server Daemon (openerp-server): 2019-04-08 13:02:47,973 30164 INFO ? openerp: OpenERP version 7.0-20130301-002301 2019-04-08 13:02:47,974 30164 INFO ? openerp: addons paths: /usr/lib/python2.6/site-packages/openerp-7.0_20130301_002301-py2.6.egg/openerp/addons 2019-04-08 13:02:47,974 30164 INFO ? openerp: database hostname: 192.168.3.17 2019-04-08 13:02:47,974 30164 INFO ? openerp: database port: 5432 2019-04-08 13:02:47,974 30164 INFO ? openerp: database user: openerp 2019-04-08 13:02:49,187 30164 INFO ? openerp.addons.google_docs.google_docs: GData lib version %s GData-Python/2.0.11 detected 2019-04-08 13:02:50,208 30164 INFO ? openerp: OpenERP server is running, waiting for connections… Exception in thread Thread-1: Traceback (most recent call last): File “/usr/lib64/python2.6/threading.py”, line 532, in __bootstrap_inner self.run() File “/usr/lib64/python2.6/threading.py”, line 484, in run self.__target(*self.__args, **self.__kwargs) File “/usr/lib/python2.6/site-packages/openerp-7.0_20130301_002301-py2.6.egg/openerp/service/wsgi_server.py”, line 427, in serve httpd = werkzeug.serving.make_server(interface, port, application, threaded=True) File “/usr/lib/python2.6/site-packages/werkzeug/serving.py”, line 402, in make_server passthrough_errors, ssl_context) File “/usr/lib/python2.6/site-packages/werkzeug/serving.py”, line 334, in init HTTPServer.init(self, (host, int(port)), handler) File “/usr/lib64/python2.6/SocketServer.py”, line 412, in init self.server_bind() File “/usr/lib64/python2.6/BaseHTTPServer.py”, line 108, in server_bind SocketServer.TCPServer.server_bind(self) File “/usr/lib64/python2.6/SocketServer.py”, line 423, in server_bind self.socket.bind(self.server_address) File “”, line 1, in bind error: [Errno 98] Address already in use

Does anyone have any idea about how to resolve the issue? Thank you