[SOLVED] Module Snapshot updated in JFrog but not local Maven

@raff I am running into an issue with the metadatadeploy 1.8-SNAPSHOT, which is not being updated despite being available in Jfrog https://openmrs.jfrog.io/openmrs/webapp/#/artifacts/browse/tree/General/snapshots/org/openmrs/module/metadatadeploy-omod/1.8-SNAPSHOT/metadatadeploy-omod-1.8-SNAPSHOT.jar

I rerun the build via CI to get a new version of the snaphsot, however my local .m2 is not updated with the snapshot even after cleaning out the local metadatadeploy cache. Running mvn clean install -U does not bring the latest version of the snapshot too.

If updating the snapshots fails, I would like to release metadatadeploy 1.8.0 so that we can use the last commit here https://github.com/openmrs/openmrs-module-metadatadeploy/commit/cef32718e5eb752421f82b7e84d3068de4c18c7d

1 Like

@ssmusoke, I see you already released 1.8.0. How did you clean out the local metadatadeploy cache? Are you sure your other project was configured to use metadatadeploy 1.8-SNAPSHOT?

@raff I have just tried to release 1.8.0 but it has failed on the mvn release:perform step with the following error https://gist.github.com/ssmusoke/b942f7b99255fc54484da3a5fec9d443

I am sure that it is not my settings since I released UgandaEMR modules on Tuesday and I have not changed any settings since then.

@raff I deleted the path metadata deploy folder in the .m2 repository cache. It does not happen only on my computer but for a colleague too

Okay, let me try to reproduce it…

@raff Sent you a patch of the generated 1.8.0 release files via PM

I’ve added a release step to the CI plan and released 1.8.1 at https://ci.openmrs.org/browse/MDEP-MDEP-33/

I’ve also changed permissions in Artifactory. I hope it will work now for you when doing releases manually. If not, I will contact jfrog to help out.

@raff Thanks - will keep you updated if we run into any more challenges

@raff Just a headsup tried to release database backup module 1.2.6 and ran into the same issue

Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:2.7:deploy (default-deploy) on project databasebackup: Failed to deploy artifacts: Could not transfer artifact org.openmrs.module:databasebackup:pom:1.2.6 from/to openmrs-repo-modules (http://mavenrepo.openmrs.org/nexus/content/repositories/modules/): Failed to transfer file: https://openmrs.jfrog.io/openmrs/modules/org/openmrs/module/databasebackup/1.2.6/databasebackup-1.2.6.pom. Return code is: 401, ReasonPhrase: Unauthorized. -> [Help 1]

Could you please verify if you have correct credentials for openmrs-repo-modules server in your settings.xml file? It’s described at https://wiki.openmrs.org/display/docs/Maven+Release+Process under Credentials to the maven repository (you need to do this once in your dev environment)

Can you login with the same credentials through the web browser at https://mavenrepo.openmrs.org/?

@raff I have double checked the credentials - updating the servers to what the wiki page says. The new error is:

Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:2.7:deploy (default-deploy) on project databasebackup: Failed to deploy artifacts: Could not find artifact org.openmrs.module:databasebackup:pom:1.2.6 in openmrs-repo-modules (http://mavenrepo.openmrs.org/nexus/content/repositories/modules/) -> [Help 1]

despite the pom being available at


Could you please paste the full log from a release build? You need to bump the version to 1.2.7 now since 1.2.6 is broken.

Thanks @raff works like a charm, not sure why it was working for some modules and not for others