Setup time zone


(Humberto Torres) #1

How do I change time zone on a Bahmni implementation? I forgot to setup this parameter when I installed it.

Thank you


(Jan Mewes) #3

This is how I resolved this issue for myself:

# Change the timezone in the setup file
sudo vi /etc/bahmni-installer/setup.yml

# Re-run the Ansible scripts. It will leave the binaries as is and update the configuration.
bahmni -i local --skip openerp,bahmni-erp-connect,bahmni-reports install

Disclaimer: I am a Bhamni novice not sure if this might have unintended side effects.


(Humberto Torres) #4

Janux, Thank you. I believe that option works only when installing Bahmni. Unfortunately I’ve installed it already and I’ve been customizing that install over the last 3 weeks.

Thank you


(sravanthi naraharisetti) #5

You can rerun the installation


(Gurpreet Luthra) #6

You can re-run the bahmni install command, and it only applies the “Delta” or the “Changes” and doesn’t repeat stuff it has already done. So, if you change the setup.yml, it should only change the timezone value and not do anything else – since thats the only thing you changed.


Change timezone in Bahmni Vagrant Box
(Humberto Torres) #7

Thank you all for your feedback, I will give it a try.

Regards


(justine etaku) #8

I did insatll bahmni vagrant and have tried editing the time zone in

/etc/bahmni-installer/setup.yml

And still not changing to the time zone.

Thanks in advance