Setting up OpenMRS SDK

i have been trying to install OpenMRS SDK on windows 10 64 bit. When i run this command “mvn org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:setup-sdk”, the operation executes successfully as shown in the screen-shot below.! image|690x431

But when i run this command: “mvn openmrs-sdk:setup”, i get erros stating “build Failure” as shown in the screen-shot below.!

I need some help from any of u guys.

Hi @jnsereko,

The error looks to me like this is due to a certificate problem. I have seen similar issues when using an older, unsupported version of Java (for example Oracle Java 8), in which the certificates are no longer sufficiently up to date. We have fixed this typically by switching to use OpenJDK 8. Hope this helps.

Best, Mike

@jnsereko and as Mike said you can get OpenJDK from https://openjdk.java.net/install/

@jnsereko What do you have for the following

  1. java -version
  2. mvn -v
  1. java version “1.8.0_221” Java™ SE Runtime Environment (build 1.8.0_221-b11) Java HotSpot™ Client VM (build 25.221-b11, mixed mode, sharing)

  2. Apache Maven 3.6.3 (cecedd343002696d0abb50b32b541b8a6ba2883f)

Maven home: C:\Maven\bin… Java version: 1.8.0_45, vendor: Oracle Corporation, runtime: C:\Program Files\Java\jdk1.8.0_45\jre Default locale: en_US, platform encoding: Cp1252 OS name: “windows 8.1”, version: “6.3”, arch: “amd64”, family: “windows”

Thanks @mseaton! let me try it out

You are using a JRE (runtime) instead of a JDK (Java Development Kit) which is the full version for development work

the full version is JDK 8 (Oracle) anyways i am getting started with using openjdk

i have installed OpenJdk as u advised me. i also have MySQL 5.6 installed But i dont know why;

  1. The i cant type the password in the command prompt on a line that states"Please specify database password (-DdbPassword) (default: ’ '): "
  2. i dont know why i keep on getting this error

i request for your help

what is your database username,is it -DbUser as to what i am seing??

yes it is the one

yes it is -DbUser

Why not create a separate user apart from root and do not use a blank password

i cant type in the password because the characters i have typed dont appear on the screen

when typing the characters never appear but they are captured,try typing in the correct ones and proceed

@jnsereko no character will appear on the screen just continue typing